94 Acura Legend Coupe:Fuel Pump relay keeps blowing - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)

Second Generation Legend (1991-1995)

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 02-15-11, 08:14 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2009
Location: Chicago
Posts: 12


iTrader Score: 0 reviews
Unhappy 94 Acura Legend Coupe:Fuel Pump relay keeps blowing

I need some help!!! Please!
Anyway my 94 Legend Coupe has blown 2 fuel pump relays. It seems to blow when i hit a hard bump. When it blows, the car shuts down and will not start again until the new relay is in.
I have new relays that i got from the junkyard, but before i can put one in, I need to figure out how why the relay is blowing. Im guessing its a loose wire somewire grounding out and blowing it. Could it be the factory alarm or the aftermarket alarm that was once installed but no longer active?

Any ideas anyone?
BlackLGNDCoupe is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-16-11, 07:45 PM   #2 (permalink)
Registered User
 
Join Date: Jul 2009
Location: Chicago
Posts: 12


iTrader Score: 0 reviews
Can a bad fuel pump cause the fuel pump relay to blow?
BlackLGNDCoupe is offline   Reply With Quote
Old 02-18-11, 10:55 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2009
Location: Chicago
Posts: 12


iTrader Score: 0 reviews
All of these smart guys on here with answers, but nobody got any ideas here? Damn!
BlackLGNDCoupe is offline   Reply With Quote
Old 02-19-11, 05:47 PM   #4 (permalink)
EDM Honda Legend Coupe
 
MikeD's Avatar
 
Join Date: Mar 2002
Location: Cologne / Germany
Posts: 4,457


Car 1: '95 EDM Legend Coupe


iTrader Score: 0 reviews
Send a message via ICQ to MikeD Send a message via AIM to MikeD Send a message via Skype™ to MikeD
Quote:
Originally Posted by BlackLGNDCoupe View Post
Anyway my 94 Legend Coupe has blown 2 fuel pump relays.
Wait a moment. We're speaking about the PGMFI Main Relay, right? This one controls all power going to the ECU and Fuel Pump. When you turn on the ignition switch to "ON" => position II. (don't turn to start) you should hear a click and a hum sound at the fuel filter. That means that the fuel pump gets energized. If you don't hear it you probably have a faulty Main Relay.

Example: If the starter cranks but won't start, then you may have a bad Main Relay!

Quote:
Originally Posted by BlackLGNDCoupe View Post
Can a bad fuel pump cause the fuel pump relay to blow?
No, usually this can't happen. Unless there's a ground wire connection somewhere in the wirings.

Quote:
Originally Posted by BlackLGNDCoupe View Post
I need to figure out how why the relay is blowing. Im guessing its a loose wire somewire grounding out and blowing it.
A "Keep Blowing Fuse" shows you, that you have anywhere in your wirings a bad short circuit or a bad ground connect. Before you take anything to a dealer be sure to check the continuity to ground on all wires. What you are doing is to test the wiring for any Ohm (Resistance) so you should read "0" for everything that you're testing that should be a connection. If you read something higher or even better if you meter says "OL" then there is an open or a break in the wire somewhere. If you meter has an audible chirp when there is a short that is even better cause then you do not have to keep your eyes on the meter. Just poke around and listen. In this case you need the Manual, chapter "Fuel Supply System" on page 6-85 up to 9-86 and the Trouble shooting Flowchart Diagrams.

Quote:
Originally Posted by BlackLGNDCoupe View Post
Could it be the factory alarm or the aftermarket alarm that was once installed but no longer active?
The OEM Factory Alarm can't be the reason, but the Aftermarket one can. It depends how it has been connected. Some Aftermarket Alarm Systems have a Engine Immobilizer which will cut off the starter system inside the PGMFI Main Relay. Just a thought.

Question: Why don't you find out what is up with the CEL light first before proceeding with the Main Relay?
__________________

EDM '95 TCS Coupe with USDM Mod's (Trunk Lid/Taillights/Cupholder/Audio Switch/Bose EQ) rolling on 225/45/17 Tires
Acura | Honda V6 Forum / Photo Gallery
English isn't my 1st language. So please consider it by way of apology of my bad grammars! Thank you.
To my Friend FUT who I unfortunately never met in person. Rest in peace, you will not be forgotten.
MikeD is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:25 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
© AutoGuide