Radiator fan problem - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)

Second Generation Legend (1991-1995)

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 02-19-12, 06:05 PM   #1 (permalink)
Registered User
 
Join Date: Jan 2012
Location: somewhere
Posts: 49


Car 1: 1994 Acrua legend Ls
Car 2: 1992 Acura Legend L


iTrader Score: 0 reviews
Radiator fan problem

Would anyone know why my 94 legend ls radiator fan keeps turning on and off even when i'm not driving the car..i check all my sensors from the manual and i cant figure out why?
akji is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-19-12, 07:06 PM   #2 (permalink)
Registered User
 
Join Date: Aug 2008
Location: Bad old Germany
Posts: 422


Car 1: Honda Legend KA7


iTrader Score: 0 reviews
Check:
-fan timer unit
or
-fan control unit.
Daniel_S is offline   Reply With Quote
Old 02-19-12, 08:49 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2012
Location: somewhere
Posts: 49


Car 1: 1994 Acrua legend Ls
Car 2: 1992 Acura Legend L


iTrader Score: 0 reviews
Alright thanks ill check it first thing tomorrow
akji is offline   Reply With Quote
Old 02-20-12, 04:33 PM   #4 (permalink)
Registered User
 
ari_one's Avatar
 
Join Date: Oct 2005
Location: Phoenix
Posts: 3,762


Car 1: 1993 Legend 6-spd
Car 2: 2004 Tahoe


iTrader Score: 63 reviews
The fan timer unit controls the fan after turning the engine off, so that would be the first to check. It is in the passenger side foot area attached to the side just below the dash.
__________________
Parting Brown, Red, and White 91 Sedans (mostly type 'F', some type 'E'):
http://www.acura-legend.com/vbulleti...-cloth-139765/


ari_one is offline   Reply With Quote
Old 02-20-12, 05:42 PM   #5 (permalink)
Registered User
 
Join Date: Jan 2012
Location: somewhere
Posts: 49


Car 1: 1994 Acrua legend Ls
Car 2: 1992 Acura Legend L


iTrader Score: 0 reviews
I was able to find both units the serials match from a 92 legend, i put them both in but my fan still hasn't turn on is it because the ecu computer didn't read the new units or the car didn't get hot enough.. if it drains my battery i'll kno there's still a problem.
akji is offline   Reply With Quote
Old 02-21-12, 08:39 AM   #6 (permalink)
Registered User
 
Join Date: Jan 2012
Location: somewhere
Posts: 49


Car 1: 1994 Acrua legend Ls
Car 2: 1992 Acura Legend L


iTrader Score: 0 reviews
Fan didnt turn on and off and my battery didnt drain so i guess im good thanks again..if anythin goes bad ill let yall kno.
akji is offline   Reply With Quote
Old 11-13-12, 04:35 PM   #7 (permalink)
Registered User
 
Join Date: Apr 2012
Location: buckley, wa
Posts: 16


Car 1: 91 legend sedan


iTrader Score: 0 reviews
i had the same problem my fan would be going on and off all day and night sometimes id be making coffee in the morning and hear the damn thing come on for no reason...i could hear the relay clicking on and off a billion times when i had the hood up....im glad i found this discussion thanks!!
kdena989 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 05:48 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
© AutoGuide