remove / clean egr valve? - The Acura Legend & Acura RL Forum
Acura Legend Forum Acura Legend Forum
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)

Second Generation Legend (1991-1995)

Acura-Legend.com is the premier Acura Legend Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 09-20-03, 08:39 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
remove / clean egr valve?

does anyone have the instruction of how to remove and clean the egr valve. the helm manual doesnt say anything other than "replace" it. Thanks
ZiGGie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-21-03, 07:53 PM   #2 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
*bump*

help please, my smog check is due soon
ZiGGie is offline   Reply With Quote
Old 09-22-03, 01:08 PM   #3 (permalink)
Registered User
 
Join Date: Jan 2002
Location: .
Posts: 9,145


Car 1: .


iTrader Score: 1 reviews
I am in the same boat. I have failed 3 times already. I don't want to pay $150 for a new valve. It might just be dirty. I talked to Tony at Velocity and he said it could be these little onles that go to the EGR. You can clean them with carb cleaner I think. Maybe some one who has done this before will chime in.
Later!
Lee
__________________
Matt planned .org to bring the people that love a vehicle together.
sleeprlegendcp is offline   Reply With Quote
Old 09-22-03, 02:38 PM   #4 (permalink)
Registered User
 
Join Date: Aug 2002
Location: Vanouver, BC
Posts: 1,103


Car 1: 1991 LS Black Sedan


iTrader Score: 0 reviews
Send a message via ICQ to Vancouver_Legend
i'd like to know also. I did a search for this and couldn't find any good detailed instructions.

help from someone who has done it?
thanks!
__________________
- 1992 Isuzu Rodeo XS 4x4
- 1991 LS Sedan - SOLD

http://www.imagestation.com/picture/...a/f8d4a62c.jpg
Vancouver_Legend is offline   Reply With Quote
Old 09-22-03, 06:24 PM   #5 (permalink)
Registered User
 
wallstrum's Avatar
 
Join Date: Jan 2002
Location: Reno, NV
Posts: 671


Car 1: '94 Black/Black GS 6-Speed (sold)


iTrader Score: 0 reviews
Send a message via AIM to wallstrum
do a search for egr valve, and look for posts by 'sean l'. he and i had quite a lengthly discussion on it. you could also email him for more details as well, as he is very helpful. good luck,

wally
__________________
2nd Generation FAQ...Click here
wallstrum is offline   Reply With Quote
Old 09-23-03, 11:24 PM   #6 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
actually that isnt the pic for the egr valve

here is the location of the egr valve



I think the green thing is the cvc valve

Last edited by ZiGGie; 09-24-03 at 01:39 AM.
ZiGGie is offline   Reply With Quote
Old 09-25-03, 12:17 AM   #7 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
np MikeD, I just hope that someone can help me out with this problem before my smog check is due. damn these strict laws
ZiGGie is offline   Reply With Quote
Old 09-28-03, 11:37 PM   #8 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
*bump*

sorry, but some of us need some help, and maybe someone in the future will run into the same problem. Hope someone can dig up some answer. Thanks
ZiGGie is offline   Reply With Quote
Old 09-29-03, 12:33 AM   #9 (permalink)
P*mp!
 
Join Date: May 2002
Location: Queenz, NY
Posts: 1,253


Car 1: 91' Vineyard Grey Metallic Sedan


iTrader Score: 0 reviews
Send a message via AIM to WicKeD LeGEnD
what book is this information coming from?!?!?.....thats incredibly accurate...my mitchell computer at work is the only one I can think of that would give me something like that....very NiCE!..........
__________________
http://www.imagestation.com/picture/...5/f8a94485.jpg

Mods:
OEM 4300K HID's (Philips)
GS Rims/ Wrapped in Toyo Proxes Tires
Custom Red Tinted Tails
2 Rockford Fosgate HE2 10's (1 Blown, Looking for Replacement, got one?, shoot me a PM)
1 Rockford Fosgate Amp (4 x 150W)
Alpine IVA-C801 Indash Multimedia Station
Alpine ERA-G320 Sound Processor
Alpine V-Power MRP-F240 4 Channel AMP
Pioneer Speakers All Around
Blaupunkt DVD-ME3 DVD/MP3/TV Tuner
WicKeD LeGEnD is offline   Reply With Quote
Old 09-29-03, 12:38 AM   #10 (permalink)
P*mp!
 
Join Date: May 2002
Location: Queenz, NY
Posts: 1,253


Car 1: 91' Vineyard Grey Metallic Sedan


iTrader Score: 0 reviews
Send a message via AIM to WicKeD LeGEnD
my egr valve is faulty....my check engine light comes on once in a blue moon.....mostly in the winter time.....this theory of the loose wires got me thinking.....maybe this is correct......Ziggie...is your check engine light on all the time??...does it come on and off??....do you notice it more in Colder Weather or in Warm weather.???...this may sound stupid.....but it's been happening to me......i PASSED inspection with flying colors.....lower than normal specs as a matter of fact.... im trying to think of a reason however for this faultyness in the wintertime...anyone have an idea why this may happen???....in the colder weather especially......the check engine light loves to come on. Ive gotten pretty used to it though,....lol
__________________
http://www.imagestation.com/picture/...5/f8a94485.jpg

Mods:
OEM 4300K HID's (Philips)
GS Rims/ Wrapped in Toyo Proxes Tires
Custom Red Tinted Tails
2 Rockford Fosgate HE2 10's (1 Blown, Looking for Replacement, got one?, shoot me a PM)
1 Rockford Fosgate Amp (4 x 150W)
Alpine IVA-C801 Indash Multimedia Station
Alpine ERA-G320 Sound Processor
Alpine V-Power MRP-F240 4 Channel AMP
Pioneer Speakers All Around
Blaupunkt DVD-ME3 DVD/MP3/TV Tuner
WicKeD LeGEnD is offline   Reply With Quote
Old 09-29-03, 02:34 AM   #11 (permalink)
Registered User
 
Join Date: Jul 2002
Location: SJ, CA
Posts: 512


Car 1: 91 Sedan


iTrader Score: 0 reviews
service manual aka helm manual.


the problem i'm having is that they engine would not die out when they do that vacume test on the egr valve.
ZiGGie is offline   Reply With Quote
Old 09-29-03, 10:43 AM   #12 (permalink)
Sr. Member
 
Join Date: Feb 2002
Location: Bay Area, CA
Posts: 314


Car 1: '94 Cashmere LS Sedan


iTrader Score: 0 reviews
Quote:
the problem i'm having is that they engine would not die out when they do that vacume test on the egr valve.
This is the same problem I had last year....your EGR ports in the intake manifold are probably clogged. Check out the link on how to fix, I did it at home for under $10 (GM top cyl cleaner was $7)

Failed 'functional' Ca. emission test (EGR) ???
__________________
Sean in Norcal
'05 Infiniti G35 Coupe
'94 Mustang Cobra
'94 Legend LS Sedan (SOLD)
'97 Lex LS400 Coach Edition
http://www.mustangmods.com/data/4358/legendsig2.jpg
Sean L is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  The Acura Legend & Acura RL Forum > Acura Legend > Second Generation Legend (1991-1995)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:55 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0
© AutoGuide