Acura Legend Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I got somebody to swap the engine fro me. Now the the car will start but idles rough and when you drive it and press the gas pedal it backfires out of the air fliter box. It also tries to cut off while idling. Also after you get where you going you cut the car off and try to start it back up Its hard to start it might take you about 15mins to get it to start no matter if the car has been sitting for a couple of hours. Can anyone help. Thanks in advance.
 

· Registered
Joined
·
4,259 Posts
ashley2011 said:
I got somebody to swap the engine fro me. Now the the car will start but idles rough and when you drive it and press the gas pedal it backfires out of the air fliter box. It also tries to cut off while idling. Also after you get where you going you cut the car off and try to start it back up Its hard to start it might take you about 15mins to get it to start no matter if the car has been sitting for a couple of hours. Can anyone help. Thanks in advance.
Rough idle: the idle speed could be off, check and see if adjustment is needed ... or, could be related to the backfire issue.

Engine backfires: incorrect ignition timing, also, problem in the secondary ignition system; spark plugs properly gap'd? wires not crossed and distributor cap/rotor are not faulty.

Hard start: sounds like your main relay is faulty... hope this helps! ;)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top