Acura Legend Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Please let me know if this helps I went through the same thing yesterday. When I pulled over it was smoking so I let it cool off,BUT MY DUMB A S S started messing with the radiator cap and it shot off and anyi freeze flew everywhere(got the burn marks to prove it) I got it towed to the mechanic and he said I need a new radiator cap. We'll see today
Did you ever figure out the overheating problem? I have a 1990 Legend V6 that overheats occasionally, only when stuck in slow traffic and not all the time. At idle no problem. Changed thermostat already and flushed system. See no leaks. Fans also come on. TIA
 

·
Registered
Joined
·
4,259 Posts
It's possible that your radiator is faulty, restricting coolant flow...
 

·
489,000 km's stil going
Joined
·
1,016 Posts
It's possible that your radiator is faulty, restricting coolant flow...
I second that one I haven't had my fans working in almost two years and I never have reached past the half way mark except once when I got stuck in a huge traffic jam. I've never has an overheating problem with my car, i'm surprised so many have over the years.
 

·
Registered
Joined
·
1,686 Posts
glad to find this thread.
well the mechanic was putting in new belts, that fucker somehow broke the radiator cap. now i think its on purpose so they can suck more money out of me, they really pissed me off.

they call and told me the radiator cap broke and will need to charge me $15 more to fix it. i was like , it wasnt broken when it got there. and he said well its either you pay to get a new one or your stucked. i feeling like yelling at them, then i start to think they might fuck up some more shit with my car and i let it go.


i saw some radiator fluids under the hood. they got a new one in.

so here;s my question. do the fan spins automatically when the car starts , or when you turn on the A/C ??? cause mine is not spinning when the car is on. and its night time , i dont want to walk outside to check it. kinda bad area around here.
 

·
Mo*or Mo**h
Joined
·
1,730 Posts
Don't know about G2 stuff. But, G1's rad fan doesn't come on until operating temp is achieved, or the A/C is turned ON, them both rad fan and condensor fan run. They also run at two speeds depending on the water or oil temp.

As for the over-heating at the top, most times this intermitent problem is due to the cooling system not being full. When filling, the thing MUST be bled from the bleed valve, then run another 20-40 minutes with the rad cap off until ALL the bubbles stop.

This engine is notorious for trapping air inside the block and making you think the thing is full when it's not.

Also, heard others say running pure water is enough to cause situational overheating on these cars. It really needs a 50/50 coolant mixuture.

I do know when it's right, you could drive all day at 90 in the desert.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top