Acura Legend Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,448 Posts
the compressor is protected by a low pressure switch which would signal a loss of refrigerant and oil. You probably have had a leak and that is why the compressor will not run. Have the system pressure tested (and when you find it's low) have it leak tested and repaired....this is usually what is wrong, the simplest things first...
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #6 ·
hey bigdad,
when u say leak is it engine oil leak or refrigrant leak?
is it compression test on refrigrant system?


my case is one day i hear weird noise from air con,suddenly smell something burnt,stopped car.
smoke coming underhood around the compressor part.
tried to start the car but wont start.found out a/c belt didnt move but trying,somehow compressor freeze up.had to cut a/c belt and turn off a/c to start the car.
since i smell something burnt i would assume its worst than a leak,wont you?
 

·
Registered
Joined
·
1,448 Posts
If you had the compressor or bearing freeze up and spin the belt, then that is a problem....you may need to replace it. However, if the compressor just fails to engage, it is likely due to the protection of the triple pressure switch sensing low refrigerant/oil. The refrigerant system also has oil in it for lubrication (not engine oil). Any good A/C shop can examine your system and most will diagnose for free (or a small charge), hoping to get the business. If yours emitted smoke when the compressor stopped, it was likely the belt that got smoked, due to compressor pulley bearing seizure. Your can have the bearing and clutch set replaced if this is the problem.
 

·
Registered
Joined
·
163 Posts
it is most likely that the compressor clutch bearings are shot...and unfortunately cannot be replaced since it is attached to the compressor itself...you need to find another compressor unit to replace it. I had that similar problem and found a replacement compressor in the junk yard for 100 bucks...i now have fr-e-e-z-ing cold air pumping out of my vents...hehe...
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top