Acura-legend.com banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,639 Posts
Discussion Starter #1
My ABS light went on a couple of days ago I dont know what it is, anybody have experience with this problem.

IM guessing ABS speed sensor, damn 120 each!

or ABS modulator damn 500 bucks!!

im basically just fu**ed
 

·
A 15yr O.G. Owner!
Joined
·
377 Posts
Many of us, including myself, have had the ABS Modulator go south and either ignore or disconnect the light. You don't have to have ABS to be able to brake normally. Your particular issue may be something else (Module or Sensor). Used Modules can be found if you look, but no gaurantee how loneg they will last. A new unit is expensive. Personally, for a 15 year old car, I'm not going to spend that kind of $$$ to replace a shot Modulator unit, especially when I just redid my brakes, rotors & new Master Cylinder. They stop my car just fine. And my ABS unit was confirmed as being in adios mode, that's why my light stays on. My shop offered to locate me a used ABS unit, but they also said it wasn't a necessary item to have functional. So I passed.

Suggest you take your car to a shop and have the exact problem confirmed.
 

·
Registered
Joined
·
1,639 Posts
Discussion Starter #3
Many of us, including myself, have had the ABS Modulator go south and either ignore or disconnect the light. You don't have to have ABS to be able to brake normally. Your particular issue may be something else (Module or Sensor). Used Modules can be found if you look, but no gaurantee how loneg they will last. A new unit is expensive. Personally, for a 15 year old car, I'm not going to spend that kind of $$$ to replace a shot Modulator unit, especially when I just redid my brakes, rotors & new Master Cylinder. They stop my car just fine. And my ABS unit was confirmed as being in adios mode, that's why my light stays on. My shop offered to locate me a used ABS unit, but they also said it wasn't a necessary item to have functional. So I passed.

Suggest you take your car to a shop and have the exact problem confirmed.
Yea true I really dont need it but i feel safer knowing my brakes wont lock up on me in an accident situation. Atleast I can pretty much skim it down to 2 things the sensors or the module only bad thing is that their both so expensive.

thanks for the input
 

·
Registered
Joined
·
1,639 Posts
Discussion Starter #5
Try pulling the code first to find out what the cause is. If it is a sensor, you should be able to pickup a used one for a reasonable price (under $50).
How do you pull the code, I thought you could only pull CEL codes not ABS light codes?
 

·
Registered
Joined
·
1,639 Posts
Discussion Starter #8
You pull the ABS codes the same way as CEL' except you watch the ABS light blinks instead of check engine blinks.
damn I didnt know that, thanks

did you damage one of the sensors while installing your suspension?
shit maybe but I put the ksports in like 3 days before the light went off, could be a possibilty tho.
 

·
Registered
Joined
·
1,961 Posts
Jump the ECU to get the code for the abs. if it give you code 1 then you need a new abs pump (mod.)
 

·
Registered
Joined
·
962 Posts
I am getting a CODE 1 also on my abs system. Where is the best place to pick up an ABS pump? What do you mean with "(mod)" in paranthesis?
Thanks.
 

·
Registered
Joined
·
206 Posts
You might want to try to bleed that ABS system before going thru the trouble of replacing the pump. (Is the pump not working?) Search on posts with my userid as I had to work my way thru code 1-2, code 2-1, and code 4-4 issues before getting my ABS lite to go off, and the ABS system back to normal. Also, are you getting a main code 1 only, without a subcode? A main code 1 only (Pump motor over-run), without a subcode, also says "motor fuse, motor relay, pressure switch" type problem. I would test the pump motor and bleed the ABS system before replacing any parts. Good luck. Ken
 

·
Registered
Joined
·
131 Posts
My ABS light went on while I was driving. The ABS no longer worked. Guys here recommended unhooking the battery to reset the ABS and-everything worked again. Worth a try!
 

·
Registered
Joined
·
1,639 Posts
Discussion Starter #15
good info here people! thanks
 

·
Registered
Joined
·
48 Posts
does is come on after u start driving in like 5min or so
my does that all the time as soon i start driving not even 5min and comes on my cousin had same problem when he had his legend he just sprayed the brakes with high preacher water in the car wash and did not show a gen on him lol its funny but it worked
 
1 - 16 of 16 Posts
Top