Acura Legend Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter · #1 ·
Does anyone w/an RM Racing intake have the the Bayou stage II chip? Any problems??? Willie from PPP suggested that my problem might be that the intake might be "borderline." In other words, not pulling in enough air that is required by the Stage II chip. Anyone ever heard this about the RM Racing intake?

Willie is going to program another chip and send it to me, but he said if I have the same problem, then my intake probably isn't sufficient. Does this make sense? Would that make the engine cut out at 4000 RPMs?!?!?
 

·
Registered
Joined
·
1,453 Posts
if you really wanna check if it's the intake, take the filter out. the 3" pipe will suc in more than enough air without a filter. i'll let you know how mine turns out. i should get my bayou chip back on monday.
-j
 

·
Registered
Joined
·
1,453 Posts
hmmm, good point. might be good to ask willie cause most of the poeple had type 1 with no tcs. i have a type 2 with tcs so maybe i'll have the same problem.
 

·
Registered
Joined
·
595 Posts
Type II with TCS with the stage II chip no problems. I don't have exhaust which is one of the "requirements" for the stage II and it still runs fine. I highly doubt your intake would be insufficient. Were there any problems before you switched chips? Perhaps the chip flash was not complete and you don't have a fuel map above a certian RPM? Just a thought.
 

·
Registered
Joined
·
223 Posts
Discussion Starter · #8 ·
Cool. It's good to know most of the chips have worked fine, especially w/an engine that's the same as mine. Hopefully, it was just an improperly programmed chip that I rec'd. I'll find out sometime next week when I get the new one.
 
1 - 8 of 8 Posts
Top