Acura Legend Forum banner
1 - 5 of 17 Posts

· I like shiny
Joined
·
14,445 Posts
Here is what I've done when swapping emblems or "shaving"

1-Heat up with blow dryer.

2-Slide fishing line behind the emblem.

3-Pull emblem off.

4-Remove adhesive with adhesive remover or something similiar

5-Then I use Poorboys Professional Polish with my Porter Cable 7424 to remove any excess adhesive that I can't rub off.

6-Poorboys SSR1 to Polish out any scratches caused by everything else.

7-Either wax the area or install new emblem.
 

· I like shiny
Joined
·
14,445 Posts
dHYUN said:
PM sent. while were on emblems, anyone have a "typeII" emblem??
Your PM is full..

dHYUN said:
hey
i really only need the "ACURA" and the "LEGEND" emblems. you can send pics to email removed
so is your car completely shaved?
later,
danny
It's not shaved. I replaced the gold with brand new chrome emblems. I totally forgot to take pics. I'll try to later on.
 

· I like shiny
Joined
·
14,445 Posts
inthavillelegend said:
Alright, so it's been said how to take the emblems off... but any tips on how to complete the "shaving" process... what to use to fill the holes, etc., because I know the holes cannot be accessed through the bottom of the trunk....
Go to a body shop, it's not like you are going to be able just stick a cork in it.

The proper thing to do would be to have a body shop weld the holes, then bondo, sand, prime, paint.
 
1 - 5 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top