Acura Legend Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter · #1 ·
It just finished raining and my driver's side footwell is all **** and gross...any ideas what might have caused this?
 

·
Registered
Joined
·
744 Posts
Look under your foot well, you will find a couple of large OE rubber stoppers (if you will), can't remember exactly what they are called. Cap, plug, something like that. Anyways, perhaps those have rotted.

KNLNGUS
 

·
Registered
Joined
·
306 Posts
Also check to make sure your drain lines on your sunroof are clear. I can't remember where this is though, I'm travelling on business and don't have access to my Helm's manual or else I'd tell you.

I had this same issue before and it was my sunroof drains that were all cloged. Once cleared, no more wet carpet :D
 

·
Registered
Joined
·
158 Posts
Discussion Starter · #4 ·
Ok, thanks guys. I will check that out. I ran some water down my drain holes not too long ago, and they drained with no problem...I am not sure what the problem is....
 

·
Registered
Joined
·
1,415 Posts
demmmmmmmm happend tu me that like 3 days ago
i just finished raining and all the floor in driver side was water
i didn't knwo what was it after i took the carpet out and dry out i figurate that the wire to my amps are going from underhood and the water just wend on the wires stright inside my car. i fixed my wires that the wodre will drop before get inside ,and i hope now is ok
 

·
Registered
Joined
·
158 Posts
Discussion Starter · #7 ·
My opening in the firewall for all my amp wires might be the problem...good point...I didnt think it would contact water though...any idea on ways to plug it up that arent permanent?
 
1 - 7 of 7 Posts
Top