Acura Legend Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Hello All,

I'm a new member so forgive me if I break any rules for posting. I have a 92 Legend Standard. I notice that while driving sometimes in D4 the D4 selection starts blinking. Any ideas?

thx in advanced

Thank you fro your responses everyone! I also noticed at the time the D4 light started blinking my gauge jumped form 75mph (my current speed) to 120. Is this related? Should I not drive the car until this thing gets fixed? Will this cause other problems.

again, thx in advance
 

·
Registered
Joined
·
168 Posts
I had same problem fixed by clipping together a loose connection on 1 of the 3 wires going to the top of the transmission. I hell of a squeeze to get to sent behind the engine from the top to get to it. I also hear it may be a loose wire by your gas pedal from previous post.
 

·
Registered
Joined
·
1,448 Posts
the blinking light alerts you to a failure somewhere in the drive line and can be decoded by using a paper clip or other connector off of the ECU/PCM computer for your car. When you tap the little connector with the ignition on the D4 light will blink out a code. One long is equal to 10, one short is 1....then you need access to the shop manual code to tell you specifically where the fault occurred. Both previous posts will cause blink. VSS failure will affect speedo operation, the connector on top of tranny leads to the lock up solenoid for torque convertor. VSS failure is fairly common. Acura will diagnose for you and charge you about 65 bux, but will apply to repair if they do it.....lol
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Thank you fro your responses everyone! I also noticed at the time the D4 light started blinking my gauge jumped form 75mph (my current speed) to 120. Is this related? Should I not drive the car until this thing gets fixed? Will this cause other problems.

again, thx in advance
 

·
Registered
Joined
·
4,106 Posts
Although I typically request that you always check for codes to determine EXACTLY what is wrong, in this instance with the erratic speedometer the problem is most probably a failing Vehicle Speed Sensor. This problem is very common. You may order the part (and any OEM parts) from Acura of Augusta (GA) 1-800-736-6818. They have the lowest prices for OEM parts.
 

·
Registered
Joined
·
4,657 Posts
Optimus it's your vehicle speed sensor.


When the speedomter acts crazy...the sensor is starting to fail. When the ECU (electronic control unit, or computer) detects this, it will flash D4 on your dashboard. Sometimes it will turn on the Check Engine light. If you do get a check engine light, it probably means a CODE has been stored. Do a search on how to get the codes.

My Vehicle Speed Sensor has been bad over a month, and I'm getting it repaired soon, the part should cost $70-100 however all throughout this time the ECU never stored the code.


Correction: I just went to check and the ECU has shown me the codes now.
 

·
Registered
Joined
·
237 Posts
I have the same problem and according the Helm Service manual you should short the service connector, the D4 light should blink four times. This indicates that the SPEED SENSOR is defective as pointed out by FutureX 2001.
You may try to reset the ECU by removing the ACG fuse in the interior fuse panel for 20 seconds to clear the code but it's not guaranteed to fix the problem.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top