Acura Legend Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
102 Posts
Discussion Starter · #1 · (Edited)
Hey guys, have a quick query for all you electrical gurus. I replaced my alt brushes today in hopes of once and for all ending the nightmare that is my on/off battery light...unfortunately driving around later today I noted that the problem still lives on!

Anywho, I'm just wondering if perhaps I should (or should have) replaced my voltage regulator while I had the damned thing open, and if anyone believes this might be the ultimate cause? One strange thing that I noted is that the brushed on my alt weren't nearly as worn as those shown in our extremely helpful DIY.

Thanks for all replies! :bowdown:

EDIT:

Was also wondering if anyone might know where the heck this piece is supposed to go? After having reseated my alt and having the belt nicely tensed again, I noticed that I had a leftover....ugh. :eek:

 

· Registered
Joined
·
1,292 Posts
It looks like you have broken off one of the contacts on the bakelite case that holds the brushes ...no wonder then that the alternator does not work. I looked at a brush holder I had in my "spares" box:




...and that metal object sure looks like one of contacts where one of the screws goes thru to hold the brush holder in place, and make electrical contact with the regulator. I know some brush holders are different: they have an "open" hole where the screw holds it in place. The one in the photo has a "closed" hole.

..Or ....did you break one of the contacts off the old brush holder case? There are no other small metal parts in the alternator that would match your left-over piece.
 

· Registered
Joined
·
4,259 Posts
OrionZite said:
Hey guys,

Was wondering if anyone might know where the heck this piece is supposed to go? After having reseated my alt and having the belt nicely tensed again, I noticed that I had a leftover....ugh. :eek:

That's the bracket for belt tensioner bolt OrionZite... long skinny bolt (post) for alternator belt cover goes thru the hole and hold it in place, U opening points to the right and that is where your bolt tensioner rest against ;)
 

· Registered
Joined
·
4 Posts
replace the banana shaped diode bridge inside your Alt
it's a common piece easily found in an Alt shop
mine cost me 50$Can
sometimes one side is toasted and light goes on and off because you have half the
wave of the alterative voltage only
easy to diy
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top