Acura Legend Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3,102 Posts
Discussion Starter · #1 ·
ok my son visor wirers somehow broke the little ones to turn on the mirror light. but anyways i guess one was touching the metal rod the sun visor slides on. and when i turned on my lights it sparked and the lights on my dash went out and i dono if its a fuse or i blew the whole wiring system someone please help.
 

·
Registered
Joined
·
3,730 Posts
CODY690 said:
ok my son visor wirers somehow broke the little ones to turn on the mirror light. but anyways i guess one was touching the metal rod the sun visor slides on. and when i turned on my lights it sparked and the lights on my dash went out and i dono if its a fuse or i blew the whole wiring system someone please help.
You blew a fuse, check the fuse box at the driver side kick panels or under the hood. Should be a fuse labeled instructment lighting or something.
 

·
Registered
Joined
·
3,102 Posts
Discussion Starter · #7 ·
yeah it sucks i was doing 125mph last night and didnt even know it haha it felt like only 100!! only going that fast because some civic and prelude were trying to mess with me and we cant ever let that happen.
 

·
Registered
Joined
·
4,106 Posts
In the under hood Fuse/Relay Block, check fuse NO.57 which is a 15 amp fuse located bottom row second one (one in the middle).
 

·
Registered
Joined
·
3,102 Posts
Discussion Starter · #10 ·
i figured it out!!! it was my right rear tail light fuse. i replaced that one and everything worked again ha. thanks for everyones help. peace. cody
 
1 - 10 of 10 Posts
Top