Acura Legend Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter · #1 ·
Hi there i have a problem. i have upgraded to dual piston calipers on my 92 legend 4 door. Everytime i brake slowly to a complete stop i hear a clicking noise but it only happens when i brake slowly. When i brake hard i dont hear the noise. i have lubed the calipers pins, checked the calipers out and they are all good. Ball joints are good, this only happens on the passenger side. When it rains i dont hear the clicking noise/cracking noise. what can this possible be? its very annoying and i would like to figure out what is causeing this cracking/clicking noise. Please someone help me out. thank you
 

·
One Meeelion HP
Joined
·
2,956 Posts
Check to see that the spring retainer inside of the caliper didnt fall out. It goes inside of the caliper itself and pushes against the pads so that they don't vibrate or "click". Also, I have seen the caliper pins wear down so much that it was causing the caliper to vibrate on its mounts.

-Matt
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #4 ·
what does the spring retainer look like? everything is bolted in correctly.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #6 ·
ok i got you now. i'm a take a look at it in the next few days and if i'll keep you updated to see if thats the problem.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top