Acura Legend Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
:mad: Went to visit the inlaws and my f#cking car got flooded. All fuses are good. I think my starter is bad( had to take a wire and touch both the + battery side and solenoid). Once the car finally started up, it sounded terrible. Valves tapping....I don't what to do. Can anyone give any advice? thanks
 

·
Registered
Joined
·
157 Posts
Number one rule of flooded electronics (at least fresh water flooded - assuming it does not rain salt water at your inlaws) - do not turn anything on until the car has dried out.

Aside: when your car perfects that anatomically impossible task, let us know 'cause g1 legends are getting a bit scarce and reproduction would be a good thing for them. Was the flooding part of the maneuver? ;)
 

·
Registered
Joined
·
2,461 Posts
Do this

Change all engine fluids, because they drank to much, you should have a fuel tank drain plug, hope you didnt have a full tank,when you replace the gas, get some of that water remover stuff they sell at pep boys. remove all spark plugs and dry them with a cloth, or by new ones, replace spark plug wires with 8mm wires. remove distibutor cap and dry the inside, it will be moist if you dont dry it, or replace it. dry out air intake hose and replace the filter , this should help. if it doesnt, Im sorry.., but thats what I had to do to my maxima. also check your vacum hoses, theres alot so be sure to replace them one by one. I really hope this helps you, It helped me.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top