Acura Legend Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I listen to music with quite a bit of bass and yesterday my rear driver's side speaker in my car has started making a loud "buzzing" noise any time there is any bass playing in the music. It's fine for highs and mids its just the bass. What is causing this? Is my speaker blown/destroyed? Can I do anything to fix it? The car is a '88 Legend L with the BOSE system... I believe that the speaker in question is 6.5"... it's round anyways. Any help in this matter would be greatly appreciated..IT'S DRIVING ME NUTS!!
 

·
Premium Member
Joined
·
9,167 Posts
It's probably a blown speaker, go to your local stereo shop and check out which 6.5" speaker you like best and replace them.
 

·
Registered
Joined
·
154 Posts
i had the same problem in my 90 LS. i pulled the deck and found out that the amp controlling my driver's side speakers was completely fried. when i installed the new deck, my buddy that works at American installation said that i needed a part put in that bypasses the amp and thus i was able to rewire those driver's side speakers and run another amp to my subs.
 

·
Registered
Joined
·
782 Posts
speaks

hey i had the same problem with my rear speakers...i would take the stock ones out and replace them because with the stock speaks ususally they come with a paper surround which tend to break down due to sun, heat & moisture in 10-15 years so thats prolly whats causing the problem the surround on ur speakers is starting to fall apart...just rip open the door and inspect the speaker
 
1 - 4 of 4 Posts
Top