Acura Legend Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
my appologies if theis issue has been covered...but info is always appreciated.

Yesterday morning, on my way to work, my check engine light came on. It did not come on on my drive home. This morning the light came on again. I checked the ECU and I have a slow and steady red blinking light, approx 1.5 seconds apart. Any ideas??:confused:
 

·
Registered
Joined
·
293 Posts
As I recall, code one indicates the front O2 sensor. Probably need replacing.
 

·
Registered
Joined
·
270 Posts
also change the rear O2 sensor while you are at it. If they have never been changed, it is advisable to change them both out.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #5 ·
Thanks, everyone

Rick90Legend & LegendGS,
you were right, it was my O2 sensor (front). 30 min after I reads your posts, I found the page with the codes. Thanks everyone!:D

Iceman22, I took your advice and had both replaced, more expensive than I was hoping for but I like to keep my L in good condition.

Side note: My mechanic theorizes that the front O2 sensor is prone to going out more often due to the leaky valve cover that leaks directly onto the sensor. He also said they get about a 4:1 ratio for replacement between the Front and rear sensors. So, there sounds like sounds like some basis for the theory.

Thanks again..:D
 

·
Registered
Joined
·
293 Posts
Actually, my rear when out at 88k miles and replaced my front sensor at 100k miles just for maintenance. Replace the top and side valve cover gaskets if they are leaking.

The O2 sensors (about $35-40 each) for the Legend are CHEAP! My Miata sensor with an OEM connection is $120.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #8 ·
cost...

the sensors were Bosch, $80 ea. Supposedly they make a generic sensor and a specific one. I, of course, chose the specific (more exspensive) sensor.

The gunk on the front sensor was there from before. I've had the valve cover replaced recently. But when I saw the two, the front was definately gunk upped and the rear was nice and clean. I definately support my mechanics theory based on what I saw... ($.02):rolleyes:
 

·
Registered
Joined
·
4,039 Posts
FutureX 2001 said:
Thanks for the prices, good to know and have on the forum
Joe Schmoe Pep Boys has a specific one for like $45 for front and $40 for rear.

The tough part is finding the rear one.

-Jose
 

·
Registered
Joined
·
293 Posts
Autozone and Advanced Auto Parts (no Pep Boys in Alabama) have front and rear - both are Bosch with OEM connectors. ## as I recall are 12050 and 12055. Sounds like your mechanic overcharged you at $80 unless that included labor - can be a pain to install.
 

·
Registered
Joined
·
864 Posts
Darth,
Hey, I actually need to replace my valve covers too. Maybe my gaskets, not sure, I wasnt listening to the mechanic (I was running really late!!! :rolleyes: ) but how much was it for you to replace them is it a DIY job? anyway thank you!

-bryan
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #13 ·
Rick90legend,

I figured I was probably paying more than 'reasonable', but I TRUST my mechanic. And where I may pay a little more on some things, I get a little less on others. He takes care of me. Besides, I am not very mechanically inclined when it comes to engines and I don't get a lot of spare time to work on the things I can do. So, it's all good.:D

Legend2die4
UUUHHHH, It probably is a DIY, but unfortunately I couldn't tell you:rolleyes: . Let me find my service record...I couldn't find my service ticket, but I found the quote from the dealer

I show, side covers
2 @ $14.78
Valve covers
2 @ $12.50
Package special
parts $39.95
labor $120.00
tax $3.30
total $163.25

hope that helps..
 

·
Registered
Joined
·
864 Posts
Thanks buddy. It gives me a good estimate about when i should stop spendin so much freakin money on my car! Errg! LoL see yuh
-bryan
 
1 - 14 of 14 Posts
Top