Acura Legend Forum banner
1 - 4 of 4 Posts

·
Moderator
Joined
·
2,873 Posts
Discussion Starter · #1 ·
Hey guys, I noticed that since I put on my prelude strut bar there has been a clicking noise from my right valve cover. I don't know what is causing this? Is it b/c the prelude bar is pressing up hard against the valve covers?


ANy ideas?


thanks
jon
 

·
502MotorSports.com
Joined
·
9,296 Posts
ouch, Jon...
Does this noise increase with throttle? I would hate to know one of those potholes in NY caused a premature failure waiting to happen. Please let us know. I have not experienced this, but I imagine anything is possible if making a hard mod like this one.
 

·
Moderator
Joined
·
2,873 Posts
Discussion Starter · #3 ·
Leon,


Here are my observations:

1.) I removed the Prelude strut bar

2.) Upon removal I noticed scuff marks in the middle. I would assume from hitting all those NYC potholes that the engine (the metal stuff between the 2 valve covers) was coming into contact with the strut bar. This problem could be alleviated perhaps by using some metal washers to the 3 mounting points for the bar.


3.) After removal of the strut bar I drove around for a few blocks and did'nt hear the clicking in the valve covers anymore. (Will report more later as I take it out to the highway tomorrow).

4.)) I noticed that both my valve covers were slightly bent due to the fact that the bar was exerting a lot of pressure on the valve covers.

5.) And lastly, I can say for certainty but the Legend did feel a littlle bit more looser w/o the bar. Indicating there are some minor improvements using this bar.
 

·
502MotorSports.com
Joined
·
9,296 Posts
Avarice said:
Leon,

Here are my observations:

1.) I removed the Prelude strut bar

2.) Upon removal I noticed scuff marks in the middle. I would assume from hitting all those NYC potholes that the engine (the metal stuff between the 2 valve covers) was coming into contact with the strut bar. This problem could be alleviated perhaps by using some metal washers to the 3 mounting points for the bar.

3.) After removal of the strut bar I drove around for a few blocks and did'nt hear the clicking in the valve covers anymore. (Will report more later as I take it out to the highway tomorrow).

4.)) I noticed that both my valve covers were slightly bent due to the fact that the bar was exerting a lot of pressure on the valve covers.

5.) And lastly, I can say for certainty but the Legend did feel a littlle bit more looser w/o the bar. Indicating there are some minor improvements using this bar.
all makes sense. Get two-three washers for the inner threads...

If this doesn't work, I am working on that strut bar if you can hold on... ;) let me know
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top