Acura Legend Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
444 Posts
Discussion Starter · #1 ·
i heard a loud ass snap when i was leaving my campus. it was a earlier in the week. i was driving past the dorms and then SNAP. i thought i got hit by some a$$hole throwing crap. i pulled to the side to kill the culprit, no one there. look at my driver's side doorsound was like right behind my seat outside)
no marks, well no new marks.

just found out what it was this morning. i think it was the cable from trunk to the driverside button. it doesn't work. is this gonna be a pain in the a$$ to fix?
 

·
GS Hog
Joined
·
7,043 Posts
Your trunk release is electrical, so there shouldn't be a cable. Have you checked the switch in your glove compartment?
 

·
Registered
Joined
·
444 Posts
Discussion Starter · #3 ·
electrical? i didn't know that. thought it was like a wire like the inside door handles...

i'll check up on it this afternoon. thanks






what in the hell was that noise then?
oh btw i'm getting a different hum from under the hood...
low pitch at low rpm
i added restore and added injector cleaner in my tank. is that sound normal? also when i refilled my tank the pump kept stopping and i had to push it back in several times cuz there was air being spit out (farting). whats all that about? should i be adding all this crap? i'm using 91 octane gas.
 

·
Registered
Joined
·
583 Posts
yo myth

I can't think of anything that would make a snap noise right behind the drivers seat.... hmmm...

is it possible that you were spinning out and tossed up a rock (or whatever) and it hit below your seat?

Does everything that worked before work the same now?

I recommend jacking up that side of the car (use jackstands) and roll around under there and see if anything obvious sticks out...

look for new leaks, frayed cables/wires, new fresh scratches/dents, etc...

does the seat sit the same? (Maybe something in it went snap)

that's about all the ideas that i have right off...
 

·
Registered
Joined
·
1,590 Posts
mythical89 said:
just found out what it was this morning. i think it was the cable from trunk to the driverside button. it doesn't work. is this gonna be a pain in the a$$ to fix?
Did you make sure the switch in the glovebox is not in valet mode?
 

·
Registered
Joined
·
386 Posts
WHAT WAS THAT LOUD NOISE???????

If I were you I'd have my timing checked. That loud sound you heard could have been your engine back firing. Also check to make sure theres nothing lose under the car. If all goes well than maybe you ran over something and it hit your underbody.:(
 

·
Registered
Joined
·
444 Posts
Discussion Starter · #12 ·
FutureX 2001 said:
Really? my 90 says, designed for 87 ocatane. I always make sure it's fed 89 though. The G2s manual says Premium 91+ only.
i got a 1990 ACURA legend manual and it says 91+. anyway i'm putting 91 cuz the gas prices in cali are starting to go up again.
1.49 for 91 last time i filled.

i don't think it backfired cuz i know exactly what that sounds like. this was more of a physical snapping sound. thats why i thought someone threw a rock and hit my car. hopefully its just the underbody.
 

·
Registered
Joined
·
270 Posts
How about looking at your fuse box... The snapping MAY have been electrical related, since you are now having problems with your trunk.... Also listen to the alternator for that humming sound... The bearings may be on their way out...
 

·
GS Hog
Joined
·
7,043 Posts
RICDOGG said:
yup, that's actually next to the blinker fluid relief tube
Yeah, I know the one you're talking about. Hate having to work around the oil filler overflow valve to get to it though.
 

·
Registered
Joined
·
583 Posts
LegendGS said:


Yeah, I know the one you're talking about. Hate having to work around the oil filler overflow valve to get to it though.
I made up a homade remedy for the above by using a one off custom billet and carbon fiber oil filler overflow valve relocation kit.
Puts it on the firewall right next to the cardboard S3/S4 blow off valve for the transmission.
 
1 - 18 of 18 Posts
Top