Acura Legend Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I am getting a code 8 which indicates a problem in the TDC sensor but the check engine light is not on. My question is what symptoms should I be looking for in regards to engine performance? I just recently had the crank angle sensor replaced. Thanks in advance.
 

·
Registered
Joined
·
293 Posts
Clear the code and see if it comes back - the CE light will come on if and when triggered again.
 

·
Registered
Joined
·
118 Posts
My check engine light did not come on either and yet my ECU was flashing code 8. The only reason I knew about it was that the engine felt low on power when going up steep hills so I thought the timing was off. I had checked the timing and it was ok - thats when I found out about the code 8. As far as I can tell, the ECU will run in failsafe mode and keep your engine running for a few months more - it is just that the engine does not run optimally 100%. My gas mileage didn't suffer noticeably during this period.

Eventually, last christmas the engine would not start so I bought a rebuilt and changed it myself within 1/2 hour (easy job). Then the engine fired up and have been running great since.

So bottom line is this - you won't notice any noticable effect on your driving, just when you go up hills and the odd hard starting. But once you change the distributor assembly, you will notice the improvement in additional power. By the way, the rebuilt cost me about $275 canadian ($175 us)

E-mail me if you want specific instructions on how to do this simple job.

Good luck!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Thanks. I bought a new one today at Acura and will replace it this weekend. I have noticed that my car feels like it is missing when driving at higher speeds. No trouble with starting though.
 
1 - 5 of 5 Posts
Top