Acura Legend Forum banner
1 - 2 of 2 Posts

·
I'van der Rohe
Joined
·
12,803 Posts
Discussion Starter · #1 ·
man.... i figure out why it has a slight bobble right. The drivers O2 sensor had not been hooked up all the way. but get this. when i hooked it back up the car just did something else as if to say "yeah aight, you found that so let go ahead and mess somim else up for you" this is really gettin me. ACURA and its special timing light is blowin me, i dont have one and i have to figure out how much the timing at the dealer is gonna cost. after long debate with the friend the helped me install these HG's we came to the conclusion that, "yep, this bad boy needs a timing adjustment"

it stalls at idle and goes past 4g's only once before it stops reving like the rev limier is at 4 g's. so if i dont have to tak it to the dealer for timing adjustment please let me know

the sheit0ns manual shows an odd looking timing light so i figured it needed a different timing light than the one that was readily accesible to me, please let know if it is a special timing light that is needed.
 

·
0000$$$$0000####0000
Joined
·
4,926 Posts
Well, since you have a 91 Legend, did you ever get the TB replaced? It was recalled for the 91 Legend models that had VINs between a certain number. The symtoms were irradic idle. The TPS is also part of the TB, so you get a new one as well. I don 't know what VIN numbers were affected though, so someone else will have to provide the link.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top