Acura Legend Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
I have an intermittent problem with my headlights (with daytime running lights). When switching on the headlights, they do not always come on right away; there is usually a delay of a few seconds to a minute. Playing with the switch does not seem to help. Is this a sign of a faulty headlight relay? If so, can somebody point me to the right part#/description so I can order one?

Thanks
 

·
Registered
Joined
·
301 Posts
The relay for the headlight is located under the hood, behind the battery.

There are 3 relays in the fuse/relay box, that look similar (1,2,3).

||{1} {3}
||{2} {4}
||
||
not all fuses represented

|| = fuses
{x} = relay

The #2 is the headlight relay.
Try swapping #1 and #2. #1 is the dimmer relay (you can live without that for a while) ;)

CORRECTION: My bad, I was replacing spark plugs today and checked the relay, the #1 and #2 that I said to swap, don't, as they are different.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #4 ·
Thanks for the responses. I placed an order for a replacement (~30$ CAD).
I didn't know it was interchangeable with the dimmer relay - that's good to know!
 

·
Registered
Joined
·
301 Posts
I believe I paid the same for my wiper relay.
It's good to have the service manual.
I've swapped relays to quickly check if one is bad.
If they look the same, pull and check the voltage.
Most relays that are similar can usually be swapped.

Just make sure you know what you are swapping, as you may not be able to start the car, but your lights may work!! :D

Good hear it was a cheap fix.
 
1 - 6 of 6 Posts
Top