Acura Legend Forum banner
1 - 6 of 6 Posts

·
Legendary P*mp
Joined
·
192 Posts
Discussion Starter · #1 ·
For some reason my blinkers is flashing really fast.... all of my bulbs are still good. but the thing is, my hazard fuse keeps burning out when i signal alot. so i just replace them about every two to three days. then my flasher blinker under the dash stopped working too! so i replaced that and now im stuck replacing the fuses again. wtf is going on here? i have a 91 legend coupe. please help me in anyway u can. thanks in advance - jimmy :confused:
 

·
Legendary P*mp
Joined
·
192 Posts
Discussion Starter · #3 ·
im positive that all the bulbs are working and blinking as it should be....but the blinking is alot faster than usual. like i said i have to replace the fuse alot....if this keeps up i might have to replace the flasher/blinker again! do u no how i can check if i its a short? thanks in advance - jimmy
 

·
Registered
Joined
·
282 Posts
your blinkers are blinking fast? damn it, thats the effect i want on my car. except i don't know what to mess around with in order to do it. i pulled out the fuse for the blinkers, but that just makes them stop working.
 

·
502MotorSports.com
Joined
·
9,296 Posts
ok, the chances of having 2-3 bad flashers is not high.
First off, replace your 194 bulbs and the 1156 bulbs or whatever they are in your rear taillight assy. If not, time to break out the trusty Helms/Haynes and a multimeter to check for a short somewhere....have you replaced your bumper lamps with clear ones?
 

·
Legendary P*mp
Joined
·
192 Posts
Discussion Starter · #6 ·
hey how do i go about doing a multimeter check? i dont no wat that meens! please break it down for me so i wont mess up mah baby.... and i dont have bumper lamps bc i have a front kit on it. thanks in advance - jimmy
 
1 - 6 of 6 Posts
Top