Acura Legend Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter · #1 ·
I got my radiator in the mail today, and after reviewing past trends in the forum and asking around, I decided to go ahead and replace the radiator myself.
I have removed all the tubes, hoses, bolts and screws but I can not seem to pull the radiator out. SInce this is my first work on the legend I am little timid about pulling too hard and breaking something. As far as I can tell, I have removed anything that would hold the radiator in place even the fans themselves. It just doesn't want to seem to come out. Am I missing something or should I just force it out??????
Please help, it hurts to see my legend on jacks:( and I am really getting tired of driving the integra:p
Thanks
 

·
Registered
Joined
·
103 Posts
Do yourself a HUGE favor and get a Helm Manual!!
Don't do a repair job without it!!!
 

·
Registered
Joined
·
163 Posts
Discussion Starter · #3 ·
can anyone scan the instructions to the helms manual and sent them to my email address???? I went out and brought the Hayes manuel because that was the only one that I could find but that didn't help at all. I found a website to order the helms but that is still gonna take at least a week before I get it. If anyone could scan those directions I would greatly appreciated. Thanks
[email protected]
 

·
Registered
Joined
·
4,106 Posts
Did you disconnect the thermosensor connector which is located in the bottom tank? Did you disconnect the fan motor connectors? I can't remember if the thermosensor and fan motor harness is attached to the fan shroud. Did you disconnect the A/T coolant hoses? There are only two bolts/brackets holding the top of the unit, and the bottom of the unit has two studs each of which are inserted into the cushions. Since the fans/fan shroud have been removed, you should be able to gently rock the radiator side to side to loosen the pins from the cushions and then lift straight up. Just be careful of the Cruise and Throttle cables as you don't want to kink them.

The HELM would not provide much additional info.
 

·
Registered
Joined
·
996 Posts
I was just under there yesterday (A/C condensor). As LPB said, it's probably the electrical connections. There are 3, if I remember correctly. 1 for each fan, and 1 for the temp sensor. Be carful of the A/C lines running around the rad, as these are pricy.
 

·
Registered
Joined
·
163 Posts
Discussion Starter · #6 ·
Thanks for the information everyone, I finally got the radiator out. I got a friend to help me and that made the biggest difference in the world. Just moving and having an extra pair of hands to move the stuff makes a huge difference.
The Radiator I brought is essentially a radiator from radiator.com just brought though ebay (koyo model) but the oem radiator cap doesn't fit. I am gonna pick up a replacment at the auto store today and see if it fits, otherwise everything fit in fine.
 
1 - 6 of 6 Posts
Top