Acura Legend Forum banner
1 - 8 of 8 Posts

· LEGENDARY MEMBER
Joined
·
1,726 Posts
Discussion Starter · #1 ·
I have the 5300k McCulloch kit. Today I fired up my headlights and the passenger light did not come on. Then I turned off, then on, and it came on??? I tried this a number of times and the passenger side light would sometimes not fire up. Any one else ever have this problem?
 

· Registered
Joined
·
428 Posts
Never happened to me before but it could be a loose connection, bad fuse, or a possible bad igniter or ballast. Check all your connections, check the fuse box, and try swapping the igniter & ballast to the other side and see if the problem follows. If it does then you probably got a bad igniter or ballast. Hopefully its still covered under warranty.
 

· Moderator
Joined
·
2,947 Posts
Boy it makes me happy I got my Autolamps kit, 4 years and 0 problems ...
=)
 

· Registered
Joined
·
1,322 Posts
stalker said:
I have the 5300k McCulloch kit. Today I fired up my headlights and the passenger light did not come on. Then I turned off, then on, and it came on??? I tried this a number of times and the passenger side light would sometimes not fire up. Any one else ever have this problem?
Sounds exactly like the problem I was having with my kit. Along with the same problems you are experience, I also noticed that when my lights weren't turned on, the one light would strobe for no reason. I sent back my ballast and igniter back for a replacement. I didn't need the hassles of having a faulty ballast and since its under warrantee, they should be sending me back a brand new one.
 

· LEGENDARY MEMBER
Joined
·
1,726 Posts
Discussion Starter · #8 ·
yesterday I went into the garage and tested it again. I turned the lights on/off about 20 times, this time the driverside didn't fire up but it only happened once. I'ts probaby not good to be turning the HIDs on and off a bunch of times right?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top