Acura-legend.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
ok my fiance has a 97 ford taurus

just recentley after the ignition switch was fixed....

the car speedomoter goes up and down like it's possesed and the car seems like it's stuck in gear or something

it also comes to a point where it wont go over 10 MPH even when you floor it...

I check the tranny fluid and it is clear just changed out at 87 K and the car just hit 100 K does anyone know whats wrong here?
 

·
Registered
Joined
·
2,944 Posts
Sounds like an ECU problem to me.


I don't know shit tho.

Take it for what it's worth :)
 

·
Registered
Joined
·
191 Posts
Discussion Starter #7
yeah i wish they had one with virtually under 60 K but thats hard to find... besides fords arent all that bad, I ve seen Taurus's go over 200 K... of course not the 500 K ive seen Legends get up too. my legend has 147 K....
 

·
because i can.
Joined
·
10,163 Posts
Any car will go over 200k miles after three engines and 7 heads :lol:

No seriously though with Fords....its the little shit that'll kill you man...
 

·
Registered
Joined
·
1,881 Posts
Sounds like the speed sensor. When you step on the gas, do the RPMs go to up to like 3000 but the tranny doesn't shift into the next gear? Same thing happened on my mom's Taurus a couple of years ago. Just buy the part on ebay and take it to your neighbourhood mechanic...don't make the mistake of going to the dealer like we did.

Also, while you're at it..drain and refill the tranny too (no power flush). Apparently Taurus trannies need regular tranny drain and refills - according to taurusclub.com; we learned this the hard way when our tranny died last summer after 8 yrs and 170K kms.
 

·
Registered
Joined
·
2,944 Posts
buy a legend for her and send the ford to the junkyard, problem fixed!
that doesn't seem quite right. Isn't the VSS just as common on The Legend?

lol

Either way, I support the trade-in for Legend program.
 
1 - 11 of 11 Posts
Top