Acura Legend Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I'm new, so lemme start w/what's up!? Anyhow, bought a 92 Legend a few months ago. It's a good looking Acura, but has had problems since I bought it. Overheating was the first MAIN problem, but then I finally solved that, and it hasn't overheated since. But I have a Idle fluctuation, and no working speedometer. Funny thing is, when I'm running 60 MPH or better, the speedo will kick in 95% of the time. And the Idle only jumps up n down half the time... When I kill the ign switch and put fire to it again, it stops for a while, then starts happening again. I will try to find the DIY on bleeding the air out of cooling properly (I call it burping) but somehow, I really don't think the coolant system is the problem. Could the irradic idle, and speedometer with a mind of it's own be a single problem?

PS I previously owned a 1990 Integra, but the difference is astounding in regards to maintenance, and motors... The B18 is a dream to work on... this 3.2 is starting to look like a nightmare... lol
 

·
Premium Well Wisher
Joined
·
2,776 Posts
I'm new, so lemme start w/what's up!? Anyhow, bought a 92 Legend a few months ago. It's a good looking Acura, but has had problems since I bought it. Overheating was the first MAIN problem, but then I finally solved that, and it hasn't overheated since. But I have a Idle fluctuation, and no working speedometer. Funny thing is, when I'm running 60 MPH or better, the speedo will kick in 95% of the time. And the Idle only jumps up n down half the time... When I kill the ign switch and put fire to it again, it stops for a while, then starts happening again. I will try to find the DIY on bleeding the air out of cooling properly (I call it burping) but somehow, I really don't think the coolant system is the problem. Could the irradic idle, and speedometer with a mind of it's own be a single problem?

PS I previously owned a 1990 Integra, but the difference is astounding in regards to maintenance, and motors... The B18 is a dream to work on... this 3.2 is starting to look like a nightmare... lol
for the speedometer problems:
Vehicle Speed Sensor...instead of doing a recall, Honda made a repair kit that replaces the electrical portion of the VSS.

eBay Motors: 1991 - 1995 ACURA LEGEND SPEED SENSOR REPAIR KIT NEW OE (item 160225397087 end time Apr-08-08 09:09:03 PDT)

$90 shipped off eBay

or check your local dealership: p/n 06560-PY3-000

when the VSS goes, the speedometer will be erratic and the odometer also will stop working (so fix it sooner than later!). eventually it will go from erratic needles that sometimes work to nada. no RPM's, no speedometer, no odometer

as for the idling problem, is the engine actually fluctuating or just the needles in the gauge?
 

·
Registered
Joined
·
1,152 Posts
1st off Welcome!
You will prob need a vehicle speed sensor for the speedo, and for the idol.. try some seafoam or you might have a BHG
 

·
Registered
Joined
·
1,152 Posts
Damn GrtOutdoorsAZ, you beat me to it..lol a min off while I was typing.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #5 ·
No blown head gasket... No water in the oil, no temp problems... No smoke. As for the fluctuation, it's the motor revving up n down rapidly, and it only does it when it's been running a bit. Someone at a Honda performance shop here says it could be a vacuum problem... But wouldn't the revs be constantly acting up if that were the case? Can Legend owners still take up on recalled parts? Also, sometimes I smell fuel when it's been running a bit....?
 

·
SGM / Type F
Joined
·
3,649 Posts
Main idle fluctuation culprits:

1. Air in cooling system (search for DIY on bleeding cooling system)
2. IACV (search for idle air control valve)
3. Fuel delivery (I suspect this in your case as you smell gas):
a. Replace fuel filter (easy, cheap, search for DIY)
b. +1 on Seafoam treatment to clean injectors
c. Search for 'fuel pump' there's a thread outlining how to test/replace.
d. Fuel Pressure Regulator. Have you tried to measure your gas mileage?
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #7 · (Edited)
Main idle fluctuation culprits:

1. Air in cooling system (search for DIY on bleeding cooling system)
2. IACV (search for idle air control valve)
3. Fuel delivery (I suspect this in your case as you smell gas):
a. Replace fuel filter (easy, cheap, search for DIY)
b. +1 on Seafoam treatment to clean injectors
c. Search for 'fuel pump' there's a thread outlining how to test/replace.
d. Fuel Pressure Regulator. Have you tried to measure your gas mileage?
1. Did the proper bleed procedure... Motor still trippin...
2. Is the IACV the same thing as the FITV??? Yes, I'm f*ckin ignorant.
3. I thought fuel filter too, and a DYI is not needed as that is an elementary procedure... lol But that will be replaced this weekend. Seafoam rules btw... I can't measure gas mileage b/c the SPEEDO isn't working! e.g. odometer is useless! FPR??? Damn, I hate to think how much that sh*t cost$...

Thanx for the advice Mr. Blaze. I will take some of those tips and act on them... Thank you all, so far...

BTW I hear a silenoid clicking right behing the driver's side firewall when the idle is acting up. It has two vacuum hoses hooked to it along with a plug. It's connected to the vac cannister. Does that help the problem description?
 

·
Registered
Joined
·
43 Posts
Before my BHG happend my car would do the same it would rev up and then down. When I was driving it was fine except the speed would drop off. I did the head gasket job and in the process I noticed the EGR pipe was clogged along with the whole chamber i had to use a screw driver to clear out the whole chamber and it took some force. Since I fixed my BHG I my car hasn't had the idle problem as well as the speed drop off. When the EGR hole gets plugged I believe it affects the vacum which causes the iradic idle. In the book it says to inspect and or clean every 2 years or 30,000 miles.

you can see a picture of where the pipe gets clogged
http://www.acura-legend.com/vbulletin/f4/egr-valve-cleaning-111880/index2.html

I hope this helps
 

Attachments

·
SGM / Type F
Joined
·
3,649 Posts
1. Did the proper bleed procedure... Motor still trippin...
2. Is the IACV the same thing as the FITV??? Yes, I'm f*ckin ignorant.
3. I thought fuel filter too, and a DYI is not needed as that is an elementary procedure... lol But that will be replaced this weekend. Seafoam rules btw... I can't measure gas mileage b/c the SPEEDO isn't working! e.g. odometer is useless! FPR??? Damn, I hate to think how much that sh*t cost$...

Thanx for the advice Mr. Blaze. I will take some of those tips and act on them... Thank you all, so far...

BTW I hear a silenoid clicking right behing the driver's side firewall when the idle is acting up. It has two vacuum hoses hooked to it along with a plug. It's connected to the vac cannister. Does that help the problem description?
+1 on the cleaning the EGR system!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top