Acura Legend Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter · #1 ·
throughout all gears and speeds engine wont run up to 6400rpm. for example ill be in second (manual tranny) and ill floor it. right when the engine hits about 5200rpm its stops there and doesnt go past that rpm all the way to 6400rpm. itll stick there and also backfire...i can hear the backfire come from the engine bay...i dont know what gives cause the car runs and accelerates fine until about 5200rpm. also in neutral when i floor it, it used to go to 6400rpm then kick back...and if i held my foot on the gas it would go back to 6400rpm and kick back...while my foot stays on the gas the rpm would pop back and forth between 6300 and 6400rpm because of the injector cut off. now when i do that, way open throttle, the engine revs to about 6200rpm and slowly drops to around 5500rpm. why i cant hit the redline like i used to and in gear it does the similar thing. i would guess timing but the care idles fine and runs fill till about that 5200rpm stuck point. so im thinking fuel related. maybe loss of pressure at high loads due to regulator or a bad fuel pump. if not that it may be something internally wrong with the engine like gasket or what else. well i hope someone here can help figure out whats the deal. i hope its something simple and replaceable and not mechanical. sorry for the length...any input would be appreciated.
 

·
88 sleeper
Joined
·
1,159 Posts
89aCuRa said:
throughout all gears and speeds engine wont run up to 6400rpm. for example ill be in second (manual tranny) and ill floor it. right when the engine hits about 5200rpm its stops there and doesnt go past that rpm all the way to 6400rpm. itll stick there and also backfire...i can hear the backfire come from the engine bay...i dont know what gives cause the car runs and accelerates fine until about 5200rpm. also in neutral when i floor it, it used to go to 6400rpm then kick back...and if i held my foot on the gas it would go back to 6400rpm and kick back...while my foot stays on the gas the rpm would pop back and forth between 6300 and 6400rpm because of the injector cut off. now when i do that, way open throttle, the engine revs to about 6200rpm and slowly drops to around 5500rpm. why i cant hit the redline like i used to and in gear it does the similar thing. i would guess timing but the care idles fine and runs fill till about that 5200rpm stuck point. so im thinking fuel related. maybe loss of pressure at high loads due to regulator or a bad fuel pump. if not that it may be something internally wrong with the engine like gasket or what else. well i hope someone here can help figure out whats the deal. i hope its something simple and replaceable and not mechanical. sorry for the length...any input would be appreciated.
that's weird...all i can suggest is to check the throttle cable to the throttle plate
 

·
Registered
Joined
·
400 Posts
Discussion Starter · #3 ·
oh so u dont think the throttle is open all the way when its floored? i checked that years ago, but i guess thats a good one to check now that this is happenin....thanks
 

·
Registered
Joined
·
1,634 Posts
Either your cat or your muffler is plugging up.
 

·
Registered
Joined
·
308 Posts
89acura,
I'd also check your second stage air intake butterfly linkages ( below throttle body) to see if they are opening freely as well as the two valcumm resevoirs that activate them. They're supposed to open at 4500rpm, if not operating correctly car will run fine below that RPM but will "starve" for air above.
 
1 - 5 of 5 Posts
Top