Acura Legend Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter · #1 ·
I recently purchased my 91 Legend L and last night after driving at night for the first time I noticed when my dash lights are on the instrument cluster lights up but none of the needles for the spedo, tach, fuel or temp light up. I tried the dimmer button but in only made the guages bright or dark. Has anyone had this experience? Are there bulbs in back of the guage cluster that only operate the needles? Or could it be fuse related. Any info would be great. I don't have a shop manual yet.
 

·
EDM Honda Legend Coupe
Joined
·
4,471 Posts
Skylane,

look into this. Maybe this helps you...

[http://www.acura-legend.com/vbulletin/showthread.php?s=&threadid=7491

Am I on the right way... you mean "cluster lights up but none of the needles for the spedo, tach, fuel or temp light up" ?

Nope, our gauge cluster doesn´t have a seperate illumination of the needles (or pins) => like Audi A6 !!! Audi has an fantastic illumination (incl. the needles!!!), that´s right. We (poor) Legend drivers have only 4 bulb (12V 5W) sockets for all transparent gauges !!!
Mike / Cologne (Germany)
 

·
0000$$$$0000####0000
Joined
·
4,926 Posts
Don't need to go taht far into the cluster. The lights that are burnt out is the overhead cluster lights. They are two 1.4W mini bulbs. After you remove the black plastic trim per other instructions in that link above, you remove the 4 phillips screws that hold teh cluster in place. From here, you simply pull the top end of the cluster a bit forward. At the top of the front part of the cluster you will see two bulb insets. Twist them out and replace them. I pesonally am using some 2.1W bulbs I bought from Checkers Auto, and have had no problems. Or, you can buy something closer to the 1.4W, or get the 1.4W from the dealer.
 

·
Registered
Joined
·
133 Posts
Discussion Starter · #7 ·
Thanks for the help again on the guage lights. Replaced them this weekend and was fairly easy except for the screw holding the bezel in above the ignition. There was two therew and I removed the wrong one and not the one directly above. Thought I was going to have to break the bezel to get it out.

I recently sold my Mustang and I will say that you guys are much more helpful than the people on the Mustang Forums. They think you are an idiot for asking a simple question.

Thanks again.
 

·
EDM Honda Legend Coupe
Joined
·
4,471 Posts
I recently sold my Mustang and I will say that you guys are much more helpful than the people on the Mustang Forums. They think you are an idiot for asking a simple question.
Thanks again. [/B]


Yeah ! Typically (some, not all !!!) Mustang driver of Mustang forum. They don´t have any intuitiveness and also arrogant. The same like Golf GTI and BMW and especially Mercedes driver here in Cologne. Some of this means, that they have an installed "right of way" !!Typically
I HATE THAT !!!
Glad that we could help you - You can count us in !!!

Mike
 
1 - 8 of 8 Posts
Top