Acura Legend Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 ·
Got my front rotors and pads done today. Was pretty easy thanks to all the info on here. I got all my stuff ready to go impact driver 8 mm screw etc. But look in the pic and see why it only took me about 40 minutes if that to do them both and thats because one of the passenger side caliper bolt is a bitch to take off. No screws to messed with.

One question tho in the boot pic is that the way that boot is supposed to be I mean not covered? Or is it messed up? Both side is like that so I assumed it is.
 

Attachments

·
Registered
Joined
·
650 Posts
It looks like you're missing the clamps that secure the boot. You should have that checked out, you don't want your axles getting ruined. It's not that hard to replace the boots yourself to be honest.
those arent the axle boots though. those are are the steering rack boots or bellows whatever you want to call them. i believe mine look like that too (which is wrong) but there have not been any problems with them.
 

·
Registered
Joined
·
1,181 Posts
Looks like the ends of the boots have torn right off after looking at your pics again. I don't think you will be able to secure them. You can replace the boots with new ones, you just have to separate the tie rod from the knuckle and then unscrew it from the steering linkage. You want to count the number of turns though and when putting it back on, turn it back in those same amount of turns. Otherwise your alignment will be off.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top