Acura Legend Forum banner
1 - 12 of 12 Posts

·
Banned
Joined
·
2,475 Posts
you are talking apples and oranges.....

whats wrong with the tranny? what condition is your car? a 93 with 107k seems too young to dump to me unless you have many issues
 

·
I swag it out...
Joined
·
1,935 Posts
i don't see how a truck is an upgrade...but your Legend has low miles. I'd keep it

Oh yeah and whats up with VA beach i'm coming out there for 4th of July. Where the chics at and what are they lookin like
 

·
Banned
Joined
·
2,475 Posts
^^ yeah that too....plus 26" rims are heavy as shit...can't be good for the suspension, gas mileage, ride comfort or lifting the fuckers onto the truck :lol:
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
it has the auto tranny and when im at a stop and take off i have to take my foot off the gas and let the car shift into second otherwise it feels like it voiently slams into second. i love the car its the std legend but i bought it from an old guy 2years ago for 1700 dollars at the time it only had 90,000 miles been a great car
 

·
Banned
Joined
·
2,475 Posts
1)Change ur tranny fluid. Spend the $140 or so at jiffy lube and see if that doesn't fix ur tranny issue.
2)If it doesn't, get it fixed with what it needs and keep it as a second weekend car.
3)Get the truck of your dreams.
4)Sell the galant to help pay for truck/Legend Repair.
5) :yes:
 

·
MAD DOG!
Joined
·
1,673 Posts
sounds more like the tranny mount more than the tranny... any problems of slipping? if youre serious about having a truck for the fact of needing a truck 26s really doesnt make sense.

as for the truck get a early early 90 toyota and do a solid front axle suspension lift and body lift and have the best truck around.... we love toyota 4x4 in hawaii... jeeps are for ********
 

·
has left.
Joined
·
4,520 Posts
Your Legend's transmission is fine.

Replace the rear transmission mount, have the transmission pan dropped and cleaned, have the screen cleaned (or replaced but it's not necessary), fill with fresh HONDA fluid (yes, from your dealer.)

Don't have Jiffy Lube do it - have a reliable independant mechanic or your dealer do it ($150 for a transmission flush from Jiffy Lube is freaking robbery... I've had mechanics do it for less than half of that!)



Don't bother with 26s on the trunk.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #11 ·
i already flushed the tranny changed the filter cleaned the magnet. never thought about the tranny mount. Has n e 1 ever had a tranny mount go bad??
As for the truck my girl has been on my ass about mariage so i told er to buy me an esclade an its on! shes workin on the loan rite now lol i figured id sell the legend and buy rims IM LOST I love the acura but i do love my girl and wouldnt mind an esclade
 

·
has left.
Joined
·
4,520 Posts
The rear mounts go bad CONSTANTLY. That's how we know it's your problem :)

A lot of people recommend polyurethane-ing the rear mount for better rigidity and improved strength.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top