Acura Legend Forum banner
1 - 13 of 13 Posts

· Who is THE MASTER?!
Joined
·
1,366 Posts
Discussion Starter · #1 ·
i have a 91 acura coupe and im loosing anti freeze like crazy but i see no leaks or dripping and the coolant bottle is not over flowing. after filling up the resevoir wit coolant after a day's worth of driving the resevoir is pretty much empty wat could be the problem??? :werd:
 

· $er1f
Joined
·
991 Posts
I would start to look at my waterpump first. Do a pressure test on the system first and you should be able to tell where the leak is coming from. My two cents.

one,
 

· Registered
Joined
·
237 Posts
imjust2fast said:
i have a 91 acura coupe and im loosing anti freeze like crazy but i see no leaks or dripping and the coolant bottle is not over flowing. after filling up the resevoir wit coolant after a day's worth of driving the resevoir is pretty much empty wat could be the problem??? :werd:
:vomit: I was having the same problem. After looking around I noticed the water pump was leaking throught the weep hole. While I was at it I went ahead and changed the timing belt. After that not a problem at all! :D
 

· Who is THE MASTER?!
Joined
·
1,366 Posts
Discussion Starter · #9 ·
oh thank god it wasnt a BHG it was just a small little hose dat leaked just like a little antifreeze so it wasnt very noticeble so i just flushed the coolant and replaced the hose and any other hose that looked worn. But wow my feels like it has alot of power i me damn i peeled out hard today :)
 

· Registered
Joined
·
73 Posts
chez1701,

Yes, It's your cap!

Bes sure to replace it with an OEM cap! I spent $20 for OEM cap after
I noticed that the new after-market cap that I purcahse was leaking fluid. Very similar to you situation!

It dosen't matter what type of radiator you have, it always helps
to stay OEM. Be sure to check for leakage from time to time.

Hugo
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top