Acura Legend Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
I bought a 1987 Legend L with a shifting problem and a bad rear main seal for $500 bucks :) It only has 142,000 miles on it. It has no rust and very few dings on the body. The interior is good too. I got a new rear main and decided to get the transmission rebuilt sense the tranny was out of the car and was acting up.


My problem is I had an overhaul kit put in it and it didnt fix the problem.
The tranny was not shifting into second gear when cold unless I put it into d2. Then when I tryed to shift it into d3 or d4 it acted like it was in neutral untill I hit 4000 rpm's, then it would go all out fast but wouldnt shift out of 2nd until it got warm. Also it grinded when I put it into pPark or nNeutral and didnt want to go into those gears when cold. When it got up to operating temp. it acted like it was in neatral and wouldnt move at all. After $600 to get it rebuilt it still doesnt shift right and slips.

Now I have to take the tranny out again and he is going to try and fix it.
He said it had to be the valve body in the transmission and the acura dealership where I live said it could be the TCM (trans.control.mod.)computer.

I was wondering if any of you might have an Idea or comment before I take the tranny out again :( I have owned honda's and acura's sence I got my drivers license and have never had any troubles like this before.
Please give me any info you have.
 

· Registered
Joined
·
4,259 Posts
nickslegend said:
I bought a 1987 Legend L with a shifting problem and a bad rear main seal for $500 bucks :) It only has 142,000 miles on it. It has no rust and very few dings on the body. The interior is good too. I got a new rear main and decided to get the transmission rebuilt sense the tranny was out of the car and was acting up.

My problem is I had an overhaul kit put in it and it didnt fix the problem.
The tranny was not shifting into second gear when cold unless I put it into d2. Then when I tryed to shift it into d3 or d4 it acted like it was in neutral untill I hit 4000 rpm's, then it would go all out fast but wouldnt shift out of 2nd until it got warm. Also it grinded when I put it into pPark or nNeutral and didnt want to go into those gears when cold. When it got up to operating temp. it acted like it was in neatral and wouldnt move at all. After $600 to get it rebuilt it still doesnt shift right and slips.

Now I have to take the tranny out again and he is going to try and fix it.
He said it had to be the valve body in the transmission and the acura dealership where I live said it could be the TCM (trans.control.mod.)computer.

I was wondering if any of you might have an Idea or comment before I take the tranny out again :( I have owned honda's and acura's sence I got my drivers license and have never had any troubles like this before.
Please give me any info you have.
Welcome aboard nickslegend...try the search function, it's ur friend...auto tranny problem(s) similar to ur's have been addressed or talked about in this forum numerous times, you'll surely find some answers ur looking for. ;) good luck!
 

· Registered
Joined
·
449 Posts
Sounds to me like you might be low on transmission fluid
Is it a sedan? The 86 and 87 sedan didn't have a TCU (transmission computer), the only thing that was electronically controled on the trasmission was the lockup clutch.
Try flushing the transmission.
 

· Registered
Joined
·
2,503 Posts
Is it possible that the cable which selects the gear is out of adjustment? I was just curious because you said it crunches when you put it in park. Anyway if it is not that pull it out and have them fix it. As everyone says, Legend=Weak Transmission.

Regards,
Steve

Love to Love the Legend
 

· Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
Thanks for all the input.
I talked to the tranny rebuilder and he is going to rebuild it again for free.
By the way. My 87' is a sedan and the acura dealership said it had a TCM, and I thought it didnt....so did you! Thanks
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top