Acura Legend Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7,230 Posts
Discussion Starter · #1 ·
HELP,
Lately my 94 L sedan has been actin up. I put a custom intake on it and i think it may be getting too much air at idle. When i shift it in to neutral, even after it is fully warmed up, it will raise RPMS to like 1500, and sometimes it will go to 2500 and then drop to 1500 and then go up and down between the two. it is freakin me out, and it doesnt do it all the time. if i drive on the highway, even for like a minute, it doesnt do it, but if i drive like 5 or 10 regular miles( in town) it still does it. and i cant figure it out.

also, when i turn on my heater, (we've had some wak weather), my heat guage goes slowly up to the red mark, and then drops back to normal. WTF

and my trunk leaked again. im about to get pissed, when i put my audio stuff in there it will get f ed up. damn i gotta find that leak.
sorry had to vent.
please help with any of these problems.thanks
peace
tnelson

BTW leon, you can change my name on the legendary legendz mailing list from T. Nelson to Tyler Nelson, it looks kinda wierd havin everbodys first names and my nick name. oh well
 

·
Registered
Joined
·
7,230 Posts
Discussion Starter · #4 ·
wow. this is the first time i have posted and not gotten a solution. i must have a tough one, dang. somebody help me (ChrisK, Leon.) btw leon, did the coolant blowoff, the revs no longer bounce, but the heat is actin up
peace
Tnelson
 

·
Registered
Joined
·
2,000 Posts
Sounds like the throttle body might be gumming up thus causing your butterfly valve or choke to be positioned off a little. This will cause the computer to deliver more fuel and then lessen the fuel before it floods out repeatedly. thus causing the surging in RPM's. I had this problem on my 92' . What I did was but some throttle body/choke cleaner and use it is directed. A immediatly saw sludge run out of the intake and my surging was cleared. -Good luck
 

·
Registered
Joined
·
595 Posts
Hate to be the bearer of bad news but you might be looking at a bad headgasket. My 94 coupe just hit 135k and I found out I have a leaking HG cyl #3, after speaking with my mechanic I found that your heating/cooling system interfaces near that cly. Hence when you turn on the heat you start drawing more air in through the leak in the HG. Check your coolant overflow tank. If it is starting to fill up past max your engine is pumping the coolant OUT of the system as the gasses escape through your head into the system. Having warm and cold spots will trick out your ECU and that might explain the surge in idle, I have a very slight surge only 300 rpms, as well.

As for the trunk leak check your drainage channels (follow where the water would logically go) for debris like pine needles etc, usually its just plugged up somewhere.

Good luck, HG repair is around 1000-1500 depending on labor. :eek:
 

·
I'van der Rohe
Joined
·
12,803 Posts
i have the same probs with my blown gasket. but i figured my bouncing idles (only randomly when cold) was due to a faulty IAC.
 

·
Registered
Joined
·
7,230 Posts
Discussion Starter · #9 ·
usually it only bounces when its cold, so it sounds like i have a problem like bang. btw i redid the colant line that used to run through the group of hoses that were connected to my old intake, and then i filled up the colant and did a bleed, like leon told me too, and i havent seen it bounce yet, but that was yesterday, and ive only had 2 starts since then, gonna go start it cold now, and see what happens.
i also have had a small amount of sludge in my intake(found this out when i took it off to do the colant mod), so i my throttle body is probably gummed up, like you said, somebody please tell me where to spray the choke cleaner and also what to get(brand).
Thanks for all the help, dont think i have a bad headgasket, but thanks, btw, what are the signs of that.
thanks
peace
Tnelson
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top