Acura Legend Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
When I step on the gas to pass a car, quickly, my battery light flashes really quick - it is so fast that it can barely be seen, but I see it - is this a problem with my alternator just starting - or will it always do that with a quick acceleration.

I also had that hot start problem when I was running a bunch of erands, wouldn't start, popped the hood, cussed, and it started right up.
 

·
Registered
Joined
·
13 Posts
Have you had your alternator belt checked or changed recently? The belt might be loose or glazed and that initial battery light flash that you see during quick acceleration could be from the belt slipping. That could also result in an under charged battery and cause starting problems.
 

·
Registered
Joined
·
400 Posts
i remember a month ago my battery light would come on but not flash, it ended up being the alternator not charging my battery, so yeah i would check your alternator and especially the condition of the belt since u say it comes on and goes off, maybe during hard acceleration it becomes loose or doesnt charge the battery. also check your battery terminals for corrosion and make sure they are tight. and check the connections near the alternator.....good luck
 

·
Registered
Joined
·
4,036 Posts
This used to happen to me in my G1.

Alternator's internals are probably rubbing and causing that.
You may be good for a while, but that alternator may be on its way out.

-Jose
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top