Acura Legend Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter · #1 ·
Well i was driving to my girls place, and i stopped at a red light while my engine was idling it automatically died out on me. Please HELP! what could be wrong with my Legend? oh yeah mines is a auto tranny.
 

·
Registered
Joined
·
275 Posts
Your battery could have died. You could have been really low on gas or have had some condensation in the tank(probably not a common problem in Oakland though).

Have you been able to start it since? If so does it keep stalling?
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #3 ·
LiasLegend said:
Your battery could have died. You could have been really low on gas or have had some condensation in the tank(probably not a common problem in Oakland though).

Have you been able to start it since? If so does it keep stalling?
All it did was just died out, and i just had to put it back to park and start up the engine again. my gas was half full and i just replaced the battery like i think half a year ago.
 

·
Registered
Joined
·
62 Posts
My car did the exact same thing a couple times my problem is the throttle position sensor.I dont know about yours it could be plenty of things. You might get some where by checking the on board diagnostic system,thats how I found out my problem.
 

·
Registered
Joined
·
703 Posts
LEgEnD4LiFe said:
this happens to me when i shift into drive from reverse while still rolling (and vice versa)
:rolleyes:
 

·
Registered
Joined
·
2,000 Posts
I had this problem before also. (My choke was sticking) I used some choke cleaner spray as directed and my problem was cleared. Give it a shot (Only 2-3 Dollars a can) before taking it to "the man"($40 minimum).
 

·
Registered
Joined
·
191 Posts
Happened to me once. Never asked questions, never happened again ;)

-GR
 
1 - 8 of 8 Posts
Top