Acura Legend Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
649 Posts
Discussion Starter · #1 ·
my first one is whenever i am driving and take my foot of the gas, when my rpm hits about 1500, it feels as though a ghost is stepping on the brake lightly and i lean a bit forward while my car feels sluggish.
also, whenever my rpm gets to 1000 it jumps up about 1300 and goes normal again. :confused:

last one, when i turn left hard my front passenger tire hit my fender. my tire size is 215/50/17. is my shock bad? i do hear a cluck sound when going over bump....thanks in advance
 

·
Spiral descent
Joined
·
4,997 Posts
From my experience and what I've read the auto transmission slowing the car down when letting off of the pedal isn't that unusual.
Do you feel drag at other RPM's when you let off the gas?

I don't know about the 1k to 1.3k jump.

It sounds like your tire hitting problem might be unrelated to your 'cluck' sound. Your balljoint could be going bad or the bushings might be going out (pretty common).
 

·
SGM / Type F
Joined
·
3,649 Posts
What are the size details on your rims (width, offset)? I think telafonic is right that the rubbing and 'cluck' :lol: sound are unrelated.
 

·
Registered
Joined
·
649 Posts
Discussion Starter · #4 ·
thank for the info, my rim are 17x7 with an offset of 40. how can i test the ballpoint or the brushing. btw...i only feel a lag when it get to about 1500 and no other rpm
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top