Acura Legend Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
317 Posts
Discussion Starter · #1 ·
ummm...i have a leak around the plate that is mounted on the front and rear of the engine...the plate is more or less vertical...anyone else have this prob....any1 know what that plate is? i don't think it's the valve cover...please reply

Juggalo 4-life
Whoop Whoop
 

·
Registered
Joined
·
400 Posts
is it a rectangular shape about 12in by 4in? it is a valve cover, our legend have two of them...front and rear of the engine...you have to replace them as well as the top valve cover gaskets. you can get them from Acura for a decent price. its hard to find the side cover gaskets from auto stores, but look around...if they are leaking it sounds like theyre due for a change.
 

·
Registered
Joined
·
583 Posts
ps, its a way easy fix. takes less than an hour. have some brake cleaner handy and a little high temp rtv helps keep the gasket in the groove while your putting the plate back on.
 

·
Registered
Joined
·
602 Posts
While you have them off you may want to use some high temp paint on them to dress them up.
 

·
Registered
Joined
·
583 Posts
i dont remember the bolt size, for the socket, but its really straight forward. no oil comes pouring out. just wipe off the mating surfaces so they are clean and dry. i used a little rtv to hold the new gasket in the sideplate groove to facilitate putting it back on. it's honestly nothing to sweat. just undo the bolts, clean it up, install new gasket, and replace. if you don't have a torque wrench, just make the bolts firm, not breaking tight (steel bolts in an aluminum part). good luck
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top