Acura Legend Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Okay guys, seems I need an ECU. My car was running hard and kinda jerky and it was turning off at stop signs and lights so I took it to the OH Mighty Mechanic. Okay, they supposedly fixed my car and when i was driving it out of the lot, guess what, it turned off. So they kept it for about five more days, seems i needed some ignition wires and spark plugs, funny cause i just had those replaced, so anyway, they checked it again and now they say I need an ECU, and it is going to cost me $375 for a rebuilt one. Can someone please help me because I have no clue if the ECU causes that or what it is supposed to cost. What are my options.
Thanks Guys
 

·
Registered
Joined
·
1,634 Posts
gaAcura88 said:
Okay guys, seems I need an ECU. My car was running hard and kinda jerky and it was turning off at stop signs and lights so I took it to the OH Mighty Mechanic. Okay, they supposedly fixed my car and when i was driving it out of the lot, guess what, it turned off. So they kept it for about five more days, seems i needed some ignition wires and spark plugs, funny cause i just had those replaced, so anyway, they checked it again and now they say I need an ECU, and it is going to cost me $375 for a rebuilt one. Can someone please help me because I have no clue if the ECU causes that or what it is supposed to cost. What are my options.
Thanks Guys
Sure, a bad ECU can cause the problem you're describing.

But from your post, it seems to me that the feeble mechanic (bad wires and plugs will not cause the problem you're having) is telling you to replace the ECU because he has no clue what the problem is. This is fine, as long as he's telling you he doesn't know what the problem is and this is a shot in the dark.

I'd get a second opinion before I replace the ECU.
 

·
Registered
Joined
·
157 Posts
I would find a new mechanic. The ECU will give you warnings if it is having problems, is the LED on the front of it flashing? If it fails, it has a backup mode and warns you when it goes to backup.

I see you are in GA. If you are near Atlanta, I have a mechanic whom I trust for many reasons and I can recommend with a completely good conscience.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
Thanks guys, Now I have one more question, where exactly would I look to get another Electronic Engine Control Unit? Would it be better to get another one rebuilt or should I try a junkyard. Also, I have noticed that the ECU is the thing that blinks, is that the engine control unit because that is the part i need. Please help me out.
Thanks :confused:
 

·
Registered
Joined
·
703 Posts
I doubt the ecu is bad. I've never seen or heard of one go bad on a Legend. It's possible, but I doubt it.
 

·
Registered
Joined
·
23 Posts
give us some more info,maybe we can fix it. what year(88?),auto/ man.
when does it act up? hot ,cold, under load is it better or worse.How long has it been doing this? ,weve had some bad gas here in minnesota that caused alot of driveabilty problems.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
It is an 88 2 door, auto trans. When I am driving, the car doesn't ride smoothly, it is kinda rough. The RPM goes up to about 4 before it changes gears and my idle is really low. Also, would it be better to get it rebuilt or to try a junk yard?
thanks
 

·
Registered
Joined
·
2,461 Posts
gaAcura88

SOUNDS LIKE YOU HAVE A VACUME LEAK. THAT HAS SOMTHING TO TO WITH THE EGR SYSTEM. A VACUME LEAK CAN CAUSE YOUR CAR TO STALL OR CUT OFF. YOU MAY WANT TO HAVE A GOOD MECH CHECK YOUR VAC HOSES.
 

·
Registered
Joined
·
17 Posts
Vcauum Leak

MrSmith is right, the problem is vacuum leak related. I traced my won't start problem for three months, end up it is vacuum leak in EGR valve. If you saw the PGMR light up then disapear, the ECU is good that mean the computer diagnosis the system and find nothing wrong. It also tell you all your system is good, nothing wrong with sensor, switch etc.
 
1 - 10 of 10 Posts
Top