Acura Legend Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
604 Posts
Discussion Starter · #1 ·
today i decided to just sit in my car and warm up the engine. i was reving on the gas for a little bit and i listen carefully and i noticed that a popping like popcorn sound was coming from the engine as soon as the gas was released after every rev. has anyone ever heard of this or had this problem. im hoping its not an egr problem. Im kinda worried because im going to make a 2000 mi trip at the end of this month.

thanks to all
 

·
Registered
Joined
·
604 Posts
Discussion Starter · #3 ·
Well.....when was the last time you changed your popcorn filter?



Anyhow...was it coming like from your intake area or out the exhaust? Rev the car by hand at the TB and try to pinpoint it....
lol, lotsa laughs. ill see, test drove it earlier. didnt seem to be anything wrong though.
 

·
Registered
Joined
·
151 Posts
lol...seriously i would check ur ehaust for lreaks and if u modd those 1st gens exhaust they cracle a little i think u r running rich change your air filter and use 87 octane

my 89 does it but that car kicks sum ass it runs like a top so i wouldnt worryas long as it has its power and stuff

oh yeah any white smoke commin out tail pipe?
or blue/white?
 

·
FRISCO LEGEND BABY!!!!
Joined
·
9,585 Posts
Mine only does it after its been drivin' around, shut off for at least 2-3 hours, turn it back on, put it to drive, then all of a sudden, POP!! I hear it coming from the TB. Whats causing it?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top