Acura Legend Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
I have a serious problem, I CAN'T LOCK MY DOORS! every time i lock my doors, it locks them. over and over again. any time i engage the power locks. they repeat locking themselves. i am affraid to lock the doors because i don't want my battery to run dry. let me know if you have any ideas.
 

·
FIXER
Joined
·
1,720 Posts
The door lock actuators are a problem on these cars. A bad one can also cause the alarm to sound randomly. Also if the key is left in the ignition it will automaticly unlock when you try to lock it. If the switch in the ignition switch malfunctions it could think the key is still in.
 

·
Registered
Joined
·
650 Posts
i have developed a somewhat similar problem which i havent seen discussed on the forums here. when i unlock my doors, i get a cycling... not when locking. this only happens on the passenger front door. i unlock the door using the power locks and it will unlock and grind for about a second. it started off as something that occurred only when it was really cold outside. now it happens every time i unlock the door. it doesnt bother me too much cuz the locks still work and the car is old, but everyone asks me WTF is wrong with ur car? when i unlock it because the grinding noise is pretty loud. im not sure if it has to do with the actuator or rubber stopper but i really dont feel like tearing my doors apart again just to fix it. i will have to if it gets worse... has anyone else seen or heard of this problem on the legend?
 

·
Registered
Joined
·
36 Posts
I also have a problem. When i get close with the key, It goes crazy, Also the passenger door when i unlock it sets off the alarm. Funny. I am used to working on American cars. these Japanese cars are a whole new set of issues. Thanks for the link. Ill have to find the part to fix it.

Edit: Just read it, sound like an long job. I too will wait til it is too far out.
 

·
Registered
Joined
·
650 Posts
I also have a problem. When i get close with the key, It goes crazy, Also the passenger door when i unlock it sets off the alarm. Funny. I am used to working on American cars. these Japanese cars are a whole new set of issues. Thanks for the link. Ill have to find the part to fix it.

Edit: Just read it, sound like an long job. I too will wait til it is too far out.
its probably the actuator. my car does the same. if i set the factory alarm and unlock with the key, it has to be on the pass. side because if i do it from the drivers side it will set the alarm off. this is the actuator going bad and not relaying to the alarm that a key was used to unlock the door (rather than someone pulling the lock tab up).
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top