Acura Legend Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,378 Posts
Discussion Starter #1
Ok..little by little i've been taking care of the legend like a baby and diagnosed a few problems wich some are being taking care about..and some i dont know what they can be...Iam going to try my best to explain it and hopefully it can help someone determine the problem...

1st. Whenever I go around a curve (right) the car runs rough (hard vibration on the pedal)...but curves going left...very smooth..almost like gliding

2nd. My rear shocks on bumps..sounds like a bubbling sound..sounds like water moving inside of a gallon! (sort of)

3rd. I have hard vibration and it feels like the car is about to cut off...I have a big muffler leak that is going to be taken care of soon..can the leak cause that? because it started to happen when I hit the chunk of ice and tore a hole in the muffler..but I dont know...

thanks in advance fellas!!
 

·
SGM / Type F
Joined
·
3,653 Posts
The first symptom sounds a lot like a broken motor/trans mount to me. The symptom of vibrating when turning right and not left could mean your motor is 'leaning' towards the left when you turn (ie away from the broken mount) and is 'settling' on the broken mount (hence no movement) when you turn left. That said, a broken rear trans mount would also cause powertrain movement when turning, but I am not familiar with autos. Describe the symptoms in more detail (is the vibration only in the pedal?) any other symptoms associated with turning? Is vibration #3 different from #1, describe it in more detail. It could be the exhaust, could be a loose/bad plug...any number of things.
 

·
Registered
Joined
·
1,378 Posts
Discussion Starter #3
The first symptom sounds a lot like a broken motor/trans mount to me. The symptom of vibrating when turning right and not left could mean your motor is 'leaning' towards the left when you turn (ie away from the broken mount) and is 'settling' on the broken mount (hence no movement) when you turn left. That said, a broken rear trans mount would also cause powertrain movement when turning, but I am not familiar with autos. Describe the symptoms in more detail (is the vibration only in the pedal?) any other symptoms associated with turning? Is vibration #3 different from #1, describe it in more detail. It could be the exhaust, could be a loose/bad plug...any number of things.
you can feel it in the pedal..but the ride itself is rough...so I guess its not only the pedal..its the whole care since the ride is rough...Iam pretty sure my mounts are messed up because when I shift from park to Drive you can feel and here it (the clunk and the engine move hard)..and thats been for a while..but that problem about rough ride around curves just started...
 

·
Registered
Joined
·
1,407 Posts
you can feel it in the pedal..but the ride itself is rough...so I guess its not only the pedal..its the whole care since the ride is rough...Iam pretty sure my mounts are messed up because when I shift from park to Drive you can feel and here it (the clunk and the engine move hard)..and thats been for a while..but that problem about rough ride around curves just started...
not sure but it could be your tie rods but that water bubbling or something like that sound I've heard it before on my 91 ls not sure what it is...can someone tell me I'm curious
 

·
Registered
Joined
·
69 Posts
first when you turn you fell vibration or noise could be hub bearing.
second noise frome the back is your rear struts are going bad.
and the vibration on the pedal could be rotors a warp.
 
1 - 11 of 11 Posts
Top