Acura Legend Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter · #1 ·
Here's the deal. I just wasted $100.00 I bought these white gauges from mmrusa.com and they suck. THe rpm limit is blue not red. Anyways since I paid for them i figured I'd use em. I changed out two of them. put it back together to make sure it worked right. THe speed gauge and gas gauge. In the instructions it tells me to gently pull the needle off and take the old covers off and put these on. I did that now my gas gauge goes all the way to full where the little needle stops it from going further. and the speedometer sticks at 35. It will gradually raise when i go faster but never the speed I'm actually going. It's not sticking to anything though
 

·
Registered
Joined
·
3,728 Posts
AAAAAAAHHHHHHHHHHHH!!!!

NEVER PULL OFF THE LEGEND NEEDLES!!!!:eek:

The only one you can safely pull of is the gas needle, all the other ones are spring loaded, once you pull them off, they won't work anymore, need to be recalibrated or replaced.

Here's how you fix the gas needle:
fill the gas tank to full. pull the needle off, then plug the gauge in the car, and turn the car on, wait like couple minutes for the pin to spin to the correct position, then plug the gas needle back in to the full position, becareful not to turn the pin underneath.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #3 ·
Thanks man. If recalibration is all it needs that's tight i get access to that **** for less than $2.00 an hour(military). If that doesn't work any other way to put these on or do i need the layovers not the whole replacements?
 

·
Registered
Joined
·
3,728 Posts
LegendOwner said:
Thanks man. If recalibration is all it needs that's tight i get access to that **** for less than $2.00 an hour(military). If that doesn't work any other way to put these on or do i need the layovers not the whole replacements?
yeah try that, if it doesn't work, you can actually replace each individual gauge in the cluster, each are held by 3 screws in the back on the cluster. if you need, I can have a spare speedo, just the speedo part, it works perfectly. I can sell it to you if you want. Good luck
 

·
Registered
Joined
·
3,198 Posts
Thats sux man:(

I have heard nothing but bad things about those aftermarket guages. People are aways saying they broke the needles or messed something up..... sounds like more trouble than its worth. They look cool though if they are done properly.... I hope you get yours going.:)
 
1 - 5 of 5 Posts
Top