Acura Legend Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
The 1st time I noticed it was the other day, I was going at 75mph or so and and all of a sudden my speedo hand dropped from 75 to 0 about 4 or 5 times before returning to normal. I didn't really notice a change in the car so I guess it's still riding normally. Then it happend a couple more times over the last few days and I noticed on the last time that my d4 light was blinking..If anyone have seen this before please help a brotha out :confused:
 

·
Registered
Joined
·
1,448 Posts
you need to replace the speed sensor. this is common. i think you can buy it at the dealer or have them do it. it doesn't cost to much. i forgot how much i paid to get it done. but i remember it didn't break my wallet.
-j
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #3 ·
aiznpride said:
you need to replace the speed sensor. this is common. i think you can buy it at the dealer or have them do it. it doesn't cost to much. i forgot how much i paid to get it done. but i remember it didn't break my wallet.
-j
Is it a do it yourself job or does it get complicated...Keep in mind I'm not a expert mechanic but I'm technical minded
 

·
Registered
Joined
·
1,448 Posts
i wouldn't say it's an easy job. but if you have a manual or even know where the sensor is, you could just replace it. i've watch the mechanic do it and it looked like he went under the car, took out the sensor and replaced it. can someone verify this? i know a lot of people here had the same issue before.

i would just call the dealer up and ask for pricing. forjust the part and the part with labor.
-j
 

·
Registered
Joined
·
702 Posts
i don't know how simple it is, but it is a quick and simple fix for a mechanic, plus it'll be under a warranty of some sort if you get a mechanic to do it. i paid $150 for new sensor and labor, so it's not that bad, but it is a very common problem.
 
1 - 7 of 7 Posts
Top