Acura Legend Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #1 ·
Why is my speedometer bouncing around?
When I drive the cable bounces no mater how fast or slow I drive, Its hard to tell if Im doing 55 or 60. any advise??
 

·
Registered
Joined
·
157 Posts
You need to lubricate the speedometer cable. It comes out of the firewall on the drivers side and runs to the transmission. There is large hex connection about half way and you can open it there and dump some graphite powder and it will help a little. The best solution is to remove the cable, pull it out of the jacket and lub with speedo cable lube. You do need to fix it though because it will break and that causes some not fun problems.
 

·
Registered
Joined
·
293 Posts
I lubed the speedo cable several months ago - very easy. Buy some oil made for speedo cables. I found some at NAPA. Then undo the hex nut, pull out top end of cable, lube it, then push it back in. It will take a little patience to get the cable back it since it fits in a certain way but just keep pushing and turning slightly until it goes in all the way. Note, the end going into the back side of the dash is squared off - this is the end that you must play with to get the cable all the way in.
 

·
Registered
Joined
·
1,634 Posts
Just don't lube the cable. Clean off any old lube first, then apply new lube.

Keep lube off of the cable for the last 6 inches or so on speedometer end. I've seen too may speedometers ruined because of the liberal application of speedo lube. Once it works it's way into the speedo head, you're really screwed.
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #6 ·
thanks peeps, Ill have to get to it as soon as I get the chance
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #7 ·
Got to it,

it was pretty easy. But after I installed it I had to leave and go some place in a hurry, and notices right away that I didnt know how fast I was moving, but I continued and said "Ill fix it when I get there", as I drove I noticed that my fuel economy was dropping dramatically (LS model) it went from like 135 distance till empty to 10 miles distance till empty in a distance of 15 miles. Man I was scared ****less. But anyway, when I got there, I re-did the speedometer cable and now it works alot better than it did before, but still, before 20mph it still bounces, but alot better than it was. OH the distance till empty gradually rose back to about 125 till empty. Thanks guys.
 

·
Registered
Joined
·
347 Posts
It's a cheap part, I replaced it as it was also making the cruise control hunt slightly after I lubed it - bad for fuel economy and annoying on the road~ 70 bucks australian.
 
1 - 8 of 8 Posts
Top