Acura Legend Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter · #1 ·
Okay I have all of these problems. I replaced the motor after I did the srs light came on. no biggie. Then the steering wheel buttons stopped working. Just yesturday the d-4 light between the rpm and spped gauge started blinking at a constitant pace. on about 1/6 second then on for about 1/6 second until car is shut off. Over drive does work though? any guesses? are these connected? Also I did a search on srs. I "think" there are no lose wires. All fuses are good.
 

·
Registered
Joined
·
62 Posts
From what I know ,when the D4 light starts blinking that means there is a possible problem in the transmission.When my ride had the same prob I took it to Trans Masters (a shop in my area)to get checked out.After the tranny inspection they told me my vehicle speed sensor was out causing the D4 ligh to blink on&off, when speed wasn't registered on my speedometer. Hope this helps. :D :D
 

·
Registered
Joined
·
1,448 Posts
could be cable reel assembly is bad or loose connection, this runs the electrics to the steering wheel accessories, including the radio controls. Also the fuse for the horn could be blown (under hood) which would explain no horn, but usually when the SRS light is on, it is the cable reel. Check the connector near your throttle pedal, sometimes your toe will catch it and pull it loose. The D4 flashing could be any number of things, it has stored a code in the computer that can be retrieved using a jumper connector and counting the number of flashes...then you need to decode using shop manual. Bad VSS is only one of many problems, a loose connection can also cause the D4 light to flash and you will get no code....seeing as you just pulled the engine, I suspect this is all due to a bad connector somewhere on engine, tranny
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #4 ·
sounds like the connection

and the speedometor is working so ill try and check the 3 plugs going to the tranny and make sure those are all secure. Man those are hard to get too.
 

·
Registered
Joined
·
1,448 Posts
I fixed my sons flashing D4 when he had tranny replaced. started about a month later...I trouble shot the problem and determined it was a loose connector at the lock up solenoid....a ***** to get to, but when I finally got to it I lubed with conductive grease and snapped together...it was loose...D4 problem gone and lock up convertor is fine now. My other son also has a Legend and he had the problem with steering wheel controls...Acura wanted to sell him a new cable reel....checked the connections and found the connector pulled loose by his foot. Reconnected and everything was fine again...hope yours is this easy..
 

·
Registered
Joined
·
275 Posts
I'm not sure about the d4 light blinking but it wouldn't hurt to check the fuses inside the car(under the dash) and those under the hood.

It maybe a waste of time, but if that's the problem then it's a cheap fix.

My radio fuse went out a few months back, which in turn caused my clock not to work, my deforster stopped working, my seat would only move backwards, and also two other things were affected(which I can not recall).
 
1 - 7 of 7 Posts
Top