Acura Legend Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
1,024 Posts
My volume control on the steering wheel just stop working yesterday. Is there some type of fuse I can check for this?

All help is needed.
FYI: btw check your cruise control and horn, if those won't work then the problem'll be your clock spring sits underneath the steering wheel air bag broken.
 

·
Registered
Joined
·
1,693 Posts
My volume control on the steering wheel just stop working yesterday. Is there some type of fuse I can check for this?

All help is needed.
Dude! I was just going to write the same post. On Thursday, my 1991 LS sedan's steering wheel volume control stopped working (both up and down). However, the center button that changes the radio presets still works and I know my horn still works. Have not tested the cruise control or tried the "flick trick", but will...

Maybe our volume control's 17 year manufacturer warranty just expired :giggle:

Really does anybody else have more ideas???

Thanks!
.
 

·
SGM / Type F
Joined
·
3,699 Posts
Dirt buildup behind the buttons themselves? Contact cleaner ought to work, is cheap and can't really hurt. The clock-spring has a 'ribbon' style wire I think??? Perhaps only one of the smaller wires in the ribbon is having an issue and hence inly some wheel controls are malfunctioning...just random ideas.
 

·
Registered
Joined
·
1,693 Posts
They are WORKING again! Thanks!

I don't believe there is a fuse for that, but sometimes dirt gets in behind the knob on the radio. Try flicking the center of the knob to loosen it up. No joke. It works.
I got them to work and I believe it was this trick that did it.

1st - I tried flicking the round volume control on the radio itself. Did not work.
2nd - Then I tried flicking the up/down controls on the steering wheel controls and it did not work.
3rd- Tried cleaning behind the up/down controls with a damp baby wipe (they have lots of uses) - did not work
4th - was a little frustrated and poked (i.e. harder than a flick...probably like poking someone in the chest) the radio volume knob and the up/down controls repeatedly (5-7 times). NOW THEY WORK AGAIN!

Thank you!
.
 

·
Banned
Joined
·
3,796 Posts
So does anyone have a problem with the radio controls on the steering wheel only working when they want to? Or doing whatever they want? Mine sometimes work fine, or don't work at all, or the volume will change the channels, or the down volume button will turn the volume up.
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #8 ·
I notice some niose something from the steering wheel itself latly. It's like when I turn the wheel sharp, I will hear this noise like the wheel is going to break. Could that be the clock spring?
 

·
Registered
Joined
·
1,693 Posts
Flickering as in turning the actual radio knob on and off?
Flicking it... like poking it...or quick jabs at it with your finger...and yes my radio knob turned on and off a few times while trying it.

But to be honest, I think it was when I did this to the steering wheel control up and down buttons that did it. I poked them with the point of my finger quickly and repeatedly like 5-7 times each (also did this to the knob on the radio) and the up/down controls started working again. Just did this Saturday night...

PS - any larger pics of your car? It looks great in your avatar/sig. I really like the sedans with the 7 spoke OEM wheels. Trying to get a set myself.
.
 

·
Registered
Joined
·
1,693 Posts
So does anyone have a problem with the radio controls on the steering wheel only working when they want to? Or doing whatever they want? Mine sometimes work fine, or don't work at all, or the volume will change the channels, or the down volume button will turn the volume up.
sorry, have not experienced that one...but sounds like something has a bad or loose connection?...total guess.
.
 

·
Registered
Joined
·
19 Posts
Have any of you guys noticed if your volume knob turns when you use your steering wheel controls? My steering wheel controls don't work and someone told me it was because the motor in my HU for the volume knob had burned out. Anyone have any idea how to remedy this?
 

·
Registered
Joined
·
1,693 Posts
Have any of you guys noticed if your volume knob turns when you use your steering wheel controls?
Yes the volume knob does move when using the volume control on the steering wheel. I do not know about a volume knob motor...but have you tried the "flick trick" discussed above. It just worked for me.
.
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #15 ·
Flicking it... like poking it...or quick jabs at it with your finger...and yes my radio knob turned on and off a few times while trying it.

But to be honest, I think it was when I did this to the steering wheel control up and down buttons that did it. I poked them with the point of my finger quickly and repeatedly like 5-7 times each (also did this to the knob on the radio) and the up/down controls started working again. Just did this Saturday night...

PS - any larger pics of your car? It looks great in your avatar/sig. I really like the sedans with the 7 spoke OEM wheels. Trying to get a set myself.
.
I will give that a shot when I get off. Question, how do you tell if the clock spring is broken?

I do have more pictures.



 

·
Registered
Joined
·
1,693 Posts
I will give that a shot when I get off. Question, how do you tell if the clock spring is broken?
I am not sure, but I would think all the steering wheel controls would not work. Is it just the volume controls that do not work? Can you change radio stations with the middle button? Does the cruise control turn on? can you increase speed? decrease? Does the horn work? I believe all of these, use the clock spring. Kind of like ptan1968 said above.

In my case, everything I just mentioned worked, except for the volume controls....and then I got them to work with the "flick trick." Also, mine, like yours, were working at the beginning of last week and stopped working on Thursday thru Saturday, until I did this fix.

Thanks for the pics.
.
 

·
Registered
Joined
·
4 Posts
Mine did the same thing. Radio volume up @ down function began to work erratically about 6 months ago. 2 months ago, it quit completely. All other steering wheel controls function properly.
From previous readings, I figured it was the clock spring.
I will be trying the "Flick trick".
I'll report the results.

1993 Acura Legend LS Coupe (190K)
 

·
Registered
Joined
·
4 Posts
I first poked the volume up & down buttons fairly hard... no results. Then I poked them as hard as I dared to without breaking something. I also did the control assembly side cover.
That did it!!! Fantastic!!! I never thought I would get to use my remote volume controls again.
Thanks for the information.
 

·
Registered
Joined
·
1,693 Posts
Yeah this is one of the simplist, but very cool tips this forum has shared.
.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top