Acura Legend Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
310 Posts
Discussion Starter · #1 ·
Well my engine install is going slow, but I came into some surprises both good and bad. Here's the thread that it all started on. See thread "Suburbanlegend engine dead."

Well after unwrapping the engine from the tons of cellophane, I noticed that there was a badge msising from this new jdm engine. The adhesive was left and I was thinking to myself that this might be a type II motor that i wanted in the first place. Turns out it is a type II alpha touring engine because of the mounts, wiring harness, and

That was a good surprise. But the bad surprsies re the oil leaks I see from the valve covers. Supposedly it only has 30,00 mile son it but it doesnt look like it, we'll see. Well I am off to my brother's and gf's graduation only to work on the install some more.

SUB
 

· Registered
Joined
·
2,843 Posts
I'd try to get the ecu as well. The VIS flaps open at different RPM's on a Type 1 vs. Type 2. Also the fuel curves are a bit different and the Type 2 ecu has a higher rev limit. To get the full effect you'll need the ecu. Congrats on the Type 2 though, should be nice.
 

· Domesticated *******
Joined
·
1,679 Posts
Very Nice :2cool:

BTW: There is no difference between the JDM Type II and USDM Type II. I got the JDM Type II in my sedan, no differences at all when compared to the GS I had a year ago.

Yes get a Type II ecu. You will be much happier with that.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top