Acura Legend Forum banner

1 - 11 of 11 Posts

·
GS Hog
Joined
·
7,043 Posts
Discussion Starter · #1 · (Edited)
This is something that has been bugging me for quite some time, and I haven't been able to figure it out.

When driving on somewhat bumpy terrain, there is this rattle that seems to come from my driver side wheel area. I always thought that it may have been the sound of my upper control arm hitting against my fender, but after grinding it down, the rattle persists. The upper control arm still rubs a little, but the sound has always remained the same. It almost sounds like something's loose. I had it looked at some time back when I was at the dealer, but they thought that it may have been my upper control arm making the noise.

Also, when shifting into gear, especially from R to D4, there is a loud *clunk* coming from the same area. It also happens when straightening out my wheels after taking a sharp turn.

Any ideas as to what may be making these noises?

Thanks!
 

·
Registered
Joined
·
282 Posts
Do you have a camber kit? One of the bolts on there could be slightly loose, which would cause a clunking type noise .. Just an idea, as I've had it happen to my car before ..
 

·
Registered
Joined
·
1,448 Posts
I agree with Leon, sounds like a tie rod popping...had the same thing when turning....sounds like the world's biggest knuckle cracking....boinnng! If its this bad you should be able to grab the tie rod and try to rotate it...if you can move it at all, it's shot.
 

·
Registered
Joined
·
847 Posts
something happened to me when I first got the car, remember?? I though it was the tie rod, axle, blah blah blah~ but my mechanic found out that it's just that things were loose~ He took everything off, retightened and greased everything for $60. No problem ever since :D
 

·
Registered
Joined
·
127 Posts
Somebody really needs to compile a "if you have these symptoms, it's probably caused by this" FAQ for us. Something like Windows Help, but for the Legend. ;)
 

·
GS Hog
Joined
·
7,043 Posts
Discussion Starter · #8 ·
Thanks fellas. Sorry, must've missed that post. :p

Now to add insult to injury... well, maybe the other way around :), I'm typing one handed coz I slammed my middle finger in the trunk of a 540. :eek:

Can I just say, *Ouch!!!* :eek:
 

·
Registered
Joined
·
847 Posts
yeah, sure:D

maybe you can take me for a spin then I'll be able to tell you if it's the same problem. BTW, you just gave me one more reason to dislike BMW, ahahaha:D
 

·
502MotorSports.com
Joined
·
9,321 Posts
Trojan Horse said:
Somebody really needs to compile a "if you have these symptoms, it's probably caused by this" FAQ for us. Something like Windows Help, but for the Legend. ;)
WEll, I am building up my FAQ....I need your guys help...if you have anything to submit, send it my way and you will get full credit for it
http://www.legendarylegendz.com/FAQ.html
 
1 - 11 of 11 Posts
Top