Acura Legend Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Okay so earlier this week i was driving around, and after i immaturely put the car in S3 and gunned it, all the electricity in my car shut off and then went back on really quickly. Now, when i depress the brake pedal, my headlights dim, and sometimes my headunit will shut off but then turn back on after a few seconds. so today i open the hood and all around my positive battery terminal there is this blue powder, kinda looks like detergent. might this be battery fluid leaking and oxidizing? i have no idea what the hell it is, some1 please help!
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #2 ·
thanks my man, ill def give that a try
 

·
Registered
Joined
·
847 Posts
G Rahn said:
This is corrosion caused by the interaction of the metals and the battery acid/gases. It may be that your intermittent electrical problem is the result of lost contact at the terminal due to the corrosion. You can clean the terminals and reduce the onset of further corrosion with the following steps:

1) Wash the corroded area around the terminals with a solution of 2 tbsp. Baking Soda dissolved in a cup of water, using a stiff bristle brush. USE EYE PROTECTION!!! and rubber gloves. Also, watch your painted surfaces and clothing.

2) Loosen and remove the terminals from the battery (negative first) and use the same method to clean the rest of the battery and terminal areas.

3) Use a small wire brush to clean the terminals, bolts and battery posts until they are nice and shiny.

4) Purchase and install anti-corrosion battery terminal washers, reinstall the terminals and use a light coat of Vaseline or high temp grease to cover the exposed metal at the terminals.

5) Immaturely put it in S3 and step on it :)
i love step 5 :D
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top